View Full Version : [ubuntu] Rhythmbox can't play today

January 20th, 2010, 04:45 PM
I was using Rhythmbox successfully yesterday. This morning the automatic updates said I should install some new packages, one of which was, I think, rhythmbox. Now it tells me that "The autoaudiosink element is missing" whenever I try to play something. What do I need to do in order for rhythmbox to work again?
Other audio programs, e.g. Audacity, work fine.

January 20th, 2010, 05:43 PM
Does audio output work properly in this dialog?:


January 21st, 2010, 10:40 AM
It didn't when I first brought it up (set to OSS). When I changed to ALSA, the test worked but Rythmbox still did not. When I changed to "auto detect" everything worked OK.

I wonder what changed it.


January 21st, 2010, 06:26 PM
Hmm. Seem intermittent. After a reboot, I started rhythmbox again and had the same error. Looked at gstream-properties and they were still set to "autodetect" and the test sound weas OK. Killed & restarted rhythmbox and all was OK again. Very strange.