PDA

View Full Version : [ubuntu] I can't increase screen resolution



chuchi
January 12th, 2010, 01:32 PM
Hello!! I can't increase my screen resolution to higher than 800x600. In Windows I have a 1024x768 resolution. This is my xorg.conf file



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
I've probed too this thread in this forum, http://ubuntuforums.org/showthread.php?t=1330434, but it not work

Many thanks to all

Grenage
January 12th, 2010, 01:43 PM
Post your monitor make/model, and the output of:


lspci | grep VGA

James Dee
January 12th, 2010, 01:55 PM
You should add in the Section Monitor (xorg.conf file) something like this:
HorizSync 30-65
VertRefresh 50-75

If I'm right the ranges could be different and they are depending on monitor type. I add this to lines in my file and it was working, I could select 1024x768 resolution.
You should make backup copy of the original xorg.conf file just in case if something goes wrong.

ajgreeny
January 12th, 2010, 02:18 PM
You may also want to add other resolution info in the file. Here's mine:-


Section "Device"
Identifier "my-radeon"
Driver "ati"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30-80
VertRefresh 50-75
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "my-radeon"
DefaultDepth 16
SubSection "Display"
Modes "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

I have a default depth of 16 as compiz will not work with my card and 24 bit colour. You may not need that, nor the Driver "ati" line

chuchi
January 12th, 2010, 07:29 PM
Grenage, here is the output:



01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 86C326 5598/6326 (rev 92)


ajgreeny,James, thanks for your help, but I don't understand your advices, I am new in ubuntu.

Many thanks to all!!

Grenage
January 12th, 2010, 08:03 PM
I'll be honest and say that I've never actually managed to help anyone with an SiS card, but let's have a go anyhow. I don't know your monitor model or specs, so I left HorizSync and VertRefresh values out. If you can find them on your manufacturer's website, add them under the Monitor section.

Once that's done, backup your existing xorg.conf:


sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup


Use the following code to replace your existing config, with your Hor/Ver sync rates. If you are struggling to find them, post your monitor make and model and I'll have a look.


Section "Monitor"
Identifier "Monitor0"
VendorName "generic"
ModelName "unknown"
Modeline "1024x768_60.00" 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync
EndSection

Section "Device"
Identifier "Device0"
VendorName "SiS"
Driver "sis"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection

If that doesn't work, try removing the driver line. If that doesn't work, try using the "vesa" driver.

chuchi
January 12th, 2010, 11:54 PM
Many thanks, Grenage. I tried your three advices but it doesn't work. My Monitor is Yuraku, model M2AABJ. Many thanks for your help Grenage!!!

chuchi
January 13th, 2010, 12:18 AM
Hello!! I have solved the problem. By searching in the web i found a similar problem, and i pasted it. But there is another problem, I have a small refresh and it is annoying. this is my xorg.conf now:



# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Silicon Integrated Systems [SiS] 86C326 5598/6326"
Driver "sis"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "StudioWorks"
Option "DPMS"
HorizSync 30-54
VertRefresh 50-120
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems [SiS] 86C326 5598/6326"
Monitor "StudioWorks"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024" "1024x768" "800x600" "720x450" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection


How can I change the refresh???
Many thanks to all!!!!!

Grenage
January 13th, 2010, 09:39 AM
You can probably scrap most of that config, unless you happen to have a wacom tablet and other inputs. The refresh is probably poor because the config file uses rates that aren't the same of your monitor.

I notice the M2AABJ is a widescreen? I just wanted to confirm that, since you said you were using 1024x768.

chuchi
January 13th, 2010, 11:20 AM
Hello Grenage!! I don't know the meaning of "wacom". I have Yuraku widescreen, this is the link, http://www.yuraku.com.sg/proddetails.asp?prodid=97&catid=28.

Grenage
January 13th, 2010, 11:32 AM
Check the config you are using; while it does contain the parts you want, it also contains a lot of junk you don't need. I was just curious why you weren't using a widescreen resolution; regardless, I'll see if I can get the rates on that model.

chuchi
January 13th, 2010, 11:37 AM
Ok Greenage, many thanks for all!! I'm sorry but I'm not english speaker, maybe my texts is not written well. I found this xorg.conf file in Internet and I copy and paste it to my xorg.conf file. I don't know the most parts of this file

Grenage
January 13th, 2010, 11:48 AM
Ok, no problem :) Try this:


Section "Device"
Identifier "Silicon Integrated Systems [SiS] 86C326 5598/6326"
Driver "sis"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Yuraku"
ModelName "M2AABJ"
Option "DPMS"
Modeline "1024x768_60.00" 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync
HorizSync 32-65
VertRefresh 57-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems [SiS] 86C326 5598/6326"
Monitor "Yuraku"
DefaultDepth 24
SubSection "Display"
Modes "1024x768" "800x600" "720x450" "720x400" "640x480"
EndSubSection
EndSection

chuchi
January 13th, 2010, 01:59 PM
Hi Grenage!!! You have solved my problem!! Now I have a 1024x768 resolution with a refresh of 75 Hz!!! Many thanks!! You are a genuine expert of Linux!!! I have a lot of learn even. Before I take your last file, I couldn't change the refresh when i went to "System->Preferences->Screen". It didn't allow me to change the refresh to other higher than 60Hz, but now, with your last advice, i have a 75Hz. Many Many thanks!!!

Grenage
January 13th, 2010, 02:51 PM
Great news!

I am definitely no expert, but I've had to play around with xorg.conf a few times. :)

lupin492
January 15th, 2010, 01:54 AM
Hi Grenage!!! You have solved my problem!! Now I have a 1024x768 resolution with a refresh of 75 Hz!!! Many thanks!! You are a genuine expert of Linux!!! I have a lot of learn even. Before I take your last file, I couldn't change the refresh when i went to "System->Preferences->Screen". It didn't allow me to change the refresh to other higher than 60Hz, but now, with your last advice, i have a 75Hz. Many Many thanks!!!

If you happen to re-read this post: Your monitor's webpage has a link to the product manual. The manual lists the possible resolution settings for your monitor model. You can get higher resolutions, and with the appropriate aspect-ratio (16:9).
But, the list shows these resolutions are possible with a 60Hz refresh rate, wich is low, you say. But your monitor is LCD and LCD's don't show flickering. ┐How does yours do it?