PDA

View Full Version : [ubuntu] 9.10 How to change audio driver to HD-ATI-SB (used in 9.04)



SR_ELPIRATA
January 12th, 2010, 04:39 AM
Hello all:

This is my 2nd try with 9.10 and audio has this screeching thingie that its driving me crazy. I've been using both 8.10 and 9.04 with perfect sound and everytime I come into 9.10 I have this horrorific sound that no matter what I do I can't fix it.

In a thread somebody suggested to change the audio channels from 5.1 to 7.1 (which made sense since my hardware really is 7.1)... but there's no 7.1 option available.

When I do lspci -v... I can see that:


00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
Subsystem: ASUSTeK Computer Inc. Device 82fe
Flags: bus master, slow devsel, latency 64, IRQ 16
Memory at fe7f4000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
Subsystem: ASUSTeK Computer Inc. Device 834d
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at fe9e8000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

And since in both 8.10 and 9.04 I had perfect sound using the HDA-ATI-SB.. Im wondering how to do the change back to that. Of these 2 listed cards, one is the HDMI and the other is the analog (which Im using as 5.1 with the already mentioned screeching sound).

Another option Im still looking around for info is how to force it to do 8 channels (7.1) instead of the apparent default of 6 (5.1). I remember there used to be a way to make the change in a simple text file.

Update: The sub is not working. Im going to try a suggestion I just saw...

Any ideas are much appreciated!

ELP

SR_ELPIRATA
January 22nd, 2010, 09:17 PM
Well, turns out that I can't change the driver :( but I got great help and this is now solved.