PDA

View Full Version : [ubuntu] My laptop screen dims even when the option is disabled.



Pawbla
January 11th, 2010, 09:24 PM
I am on Ubuntu Studio 9.04, and I have an oldish Toshiba laptop. I've disabled screen dimming as I don't know how to get it bright again (tried multiple things but no luck). Also I have no use for it since my battery does not work so it has to be on AC power to work.
I was wondering if anybody could help me to disable this? I've tried with the gnome power manager but no luck.
Or you could tell me how to brighten it again o.o. I've always used desktop PCs (I'm kinda new to this laptop) but as far as I remember when I've used laptops the power button used to brighten the screen? Or does Ubuntu have some weird key combo to brighten it? I feel so stupid not knowing xD.

warfacegod
January 11th, 2010, 09:52 PM
On my Toshiba Satellite P25-s607 holding Fn (between Ctrl and Alt) and tapping F6 dims the screen, Fn F7 will brighten. Remember, LCDs will slowly grow dimmer over the years and lose vibrancy. You may not be able to get it any brighter.

Pawbla
January 11th, 2010, 09:56 PM
That is not the problem. The problem is with the screen dimming that supposedly is for saving power. I'm perfectly okay with the normal brightness, though, but my Fn key seems to do nothing with brightness (whether it's brighten or dim). Thanks for your suggestion, anyways (:

J V
January 11th, 2010, 09:57 PM
Just throwing this out here: Screensaver?

Pawbla
January 11th, 2010, 10:04 PM
Screensaver what? You think it's my screensaver?
My screensaver is supposed to be those asterisks. Anyways, it happens when I close the laptop and after a long period of inactivity (past the screensaver). I can't go back from there. I can still see my icons and move around, but everything is really dim, almost blacked out. I can see well enough to, from memory, restart the PC. I can use the other screen if not. That is kinda weird, but my other screen isn't dimmed even if it's supposed to mirror the screens. I don't know if that is supposed to happen. But I prefer using my laptop screen because well, my keyboard is right in the front of it.
Or what did you mean? That I have to disable the screensaver too?

warfacegod
January 11th, 2010, 10:22 PM
Sounds like it's trying shut off the screen. Go to power management and set "put display to sleep" to never.

Pawbla
January 11th, 2010, 11:39 PM
I already did, that's why I said that even when the option is disabled. Maybe I didn't word it properly.

Put the computer to sleep when inactive for: Never
When laptop lid is closed: Do nothing
Put display to sleep when inactive for: Never
Set display brightness to: 100%
Dim display when idle: unchecked box.

warfacegod
January 11th, 2010, 11:53 PM
That is kinda weird, but my other screen isn't dimmed even if it's supposed to mirror the screens. I don't know if that is supposed to happen

It's not. I'll bet 5 in the currency of your choice that your LCD is shot, crapped out, kapput, and mostly dead. Basically, the extreme of what I was talking about in my first post.

Pawbla
January 11th, 2010, 11:56 PM
It's not. I'll bet 5 in the currency of your choice that your LCD is shot, crapped out, kapput, and mostly dead. Basically, the extreme of what I was talking about in my first post.

Euros please. They are worth like five pesos each.
Well, it does work ON WINDOWS, and it does work normally except when I close the laptop. So I don't see any reason to believe it's broken itself. Normally, it's like the other screen, it just has different colors because my other screen is adjusted differently to clearly see the photographs true colors.

By the way, it's not THAT old.

warfacegod
January 12th, 2010, 12:10 AM
Euros please. They are worth like five pesos each.
Well, it does work ON WINDOWS, and it does work normally except when I close the laptop. So I don't see any reason to believe it's broken itself. Normally, it's like the other screen, it just has different colors because my other screen is adjusted differently to clearly see the photographs true colors.

By the way, it's not THAT old.

You dual boot with Windows and it doesn't do it in Windows? Ok, I'm stumped. Try looking in the Configuration Editor. You got all your updates?

Your euros are in the mail, I sent them Fedex Ground.

1 computer year = 20 people years

It's like dog years but worse.

Pawbla
January 12th, 2010, 01:20 AM
YESSS fixed. I had already been in the Configuration Editor, but I had skipped an option.
Thanks a bunch!

I used to dual boot, but the problem was present before me erasing Windows. So I kinda guessed the problem wasn't there, haha.

What leaves me with the question... how can I brighten again the screen after dimming? Moving mouse, pressing keys, key combos, power button, nothing works. But luckily it's not needed now :)

warfacegod
January 12th, 2010, 01:22 AM
Sure, sometimes even a shot in the dark works. Does this mean I get my euros back?

Miljet
January 12th, 2010, 02:00 AM
Try adding the brightness applet to your top panel.

Right click an empty space on the panel, click add to panel, and brightness applet.

Disclaimer: I have never used it, but know that it is there.

Pawbla
January 12th, 2010, 02:40 AM
Haha, yes, as a thank you gift? Or something like that.

The brightness applet makes my computer freeze or something like that. I donīt exactly remember but it was something bad and Iīm not willing to try again right now.