PDA

View Full Version : [ubuntu] Another Firefox/laptop not working, pls help



mnormand
January 10th, 2010, 04:57 AM
Almost have everything working, almost...! Firefox will not connect to any websites.

Laptop: Toshiba Satellite A45-S250
Internal wireless card: Atheros AR5001X+

I've read lots of the related threads on Firefox here, but still a noob. Would love someone to walk me thru this....

Fresh install of Ubuntu.
Laptop connects with wireless router, no issues. Full strength, 5 bars.

Can sucessfully ping router using 192.168.1.1 and bring up router software/setup/etc, no issues.
Can successfully ping another Windows pc in the workgroup here in my office by pinging its IP, no issues, no errors, etc.
Tried the IPV6 true/false method, no luck either way.
Used Update Manager (via cat5 cable) to upgrade everything it saw fit.
Still cannot open any websites via wireless... just get that rotating cursor.
update: trying Update Manager to get updates via wireless...its just hanging at "downloading file 1 of 15"


Any step by step help most appreciated. I'm loving Ubuntu, but this is a deal breaker!

mn@mn-laptop:~$ lspci -mn
00:00.0 "0600" "8086" "3580" -r02 "1179" "0001"
00:00.1 "0880" "8086" "3584" -r02 "1179" "0001"
00:00.3 "0880" "8086" "3585" -r02 "1179" "0001"
00:02.0 "0300" "8086" "3582" -r02 "1179" "0002"
00:02.1 "0380" "8086" "3582" -r02 "1179" "0002"
00:1d.0 "0c03" "8086" "24c2" -r03 "1179" "0001"
00:1d.1 "0c03" "8086" "24c4" -r03 "1179" "0001"
00:1d.7 "0c03" "8086" "24cd" -r03 -p20 "1179" "0001"
00:1e.0 "0604" "8086" "2448" -r83 "" ""
00:1f.0 "0601" "8086" "24cc" -r03 "" ""
00:1f.1 "0101" "8086" "24ca" -r03 -p8a "1179" "0001"
00:1f.5 "0401" "8086" "24c5" -r03 "1179" "0241"
00:1f.6 "0703" "8086" "24c6" -r03 "1179" "0001"
01:05.0 "0200" "168c" "0013" -r01 "144f" "7058"
01:07.0 "0c00" "104c" "8023" -p10 "1179" "0001"
01:08.0 "0200" "8086" "103d" -r83 "1179" "0001"
01:0b.0 "0607" "1179" "0617" -r33 "1179" "0001"
01:0d.0 "0880" "1179" "0805" -r05 "1179" "0001"
mn@mn-laptop:~$ lshw -C Network
WARNING: you should run this program as super-user.
*-network:0
description: Wireless interface
product: Atheros AR5001X+ Wireless Network Adapter
vendor: Atheros Communications Inc.
physical id: 5
bus info: pci@0000:01:05.0
logical name: wmaster0
version: 01
serial: 00:90:96:7e:06:8d
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list logical ethernet physical wireless
configuration: broadcast=yes driver=ath5k ip=192.168.1.105 latency=168 maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11bg
resources: irq:22 memory:cfff0000-cfffffff
*-network:1
description: Ethernet interface
product: 82801DB PRO/100 VE (MOB) Ethernet Controller
vendor: Intel Corporation

puppywhacker
January 10th, 2010, 12:14 PM
if you can ping everything you have either problems wih dns or with routing. All the other stuff you mentioned is already working.

Disabling IPv6 for instance is needed for voodoo practices only and the lspci is not relevent since your network is already up and running.


cat /etc/nsswitch.conf
should contain a line with hosts: and then ???


cat /etc/resolv.conf
(should probably contain 192.168.1.1 or a public address from your provider or opendns)


ip route
(should contain a default gateway as last line, probably 192.168.1.1)

Also make sure you don't specify a proxy if you don't have one (most likeley), or specify a proxy at system/preferences/networkproxy if you do have one (less likely)

mnormand
January 10th, 2010, 04:04 PM
I was trying to clarify everything I could think of, and one more point...

I can ping my local pc's hung off this router, as well as the router.

But I can't ping anything outside of the router, like yahoo, google, etc.

All other pc's here are windows and access the internet with no problems.
That being said, here are the results of your commands...




mn@mn-laptop:~$ cat /etc/nsswitch.conf
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis
mn@mn-laptop:~$ cat /etc/resolv.conf
# Generated by NetworkManager
domain lusfiber.net
search lusfiber.net
nameserver 69.1.184.66
nameserver 69.1.184.67
mn@mn-laptop:~$ iproute
iproute: command not found
mn@mn-laptop:~$ ip route
192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.105 metric 2
default via 192.168.1.1 dev wlan0 proto static
mn@mn-laptop:~$

Iowan
January 10th, 2010, 05:01 PM
Can you ping internet by IP address (74.125.95.104 or 209.191.93.53)?

puppywhacker
January 10th, 2010, 05:43 PM
Hi, I didn't mean to sound like an ***, a bunch of letters may bend the intention a bit.

Like Iowan said, can you ping google? or can you even browse them by ip-address? http://74.125.95.104/ Because I'm suspecting the problem you're having is with dns nameresolving, the route seems fine and the dns-servers seem fine, I guess the part where it goes wrong is this one. You can remove it and see if it improves your situation. Although it still may be proxy settings.

mdns4_minimal [NOTFOUND=return]

mnormand
January 11th, 2010, 03:37 AM
Nope I can't ping, or browse any of those suggestions via wireless. It works fine with wired.
It just hangs with terminal or firefox.




mdns4_minimal [NOTFOUND=return][/quote]

I'm assuming execute this command in terminal? I did and it comes back "command not found"


thx to both of you for continuing to look at my problem. :D

puppywhacker
January 11th, 2010, 03:44 PM
In the file /etc/resolv.conf you reported back that this was the outcome

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
I thought the mdns4_minimal was breaking your internet. mdns is the avahi way of resolving a name to an ip-address. But since you can't ping or browse based on ip-address either you must have a routing problem.

What makes this a bit more complicated is that you have a wired and wireless connection which are on two physically different networks, but are in the same ip address range "192.168.1.X". This is one possible point where the routing from your laptop to your router is wrong and/or the routing from your router to your laptop is faulty.

Another possibility is that your router has a MAC filter on the wireless, which will disallow your laptop from using the internet, but that should also have prevented it from pinging the rest of the nodes.

A third problem may be firewall filtering on you laptop, you can temporarily flush the iptable rules with "sudo iptables -F" a reboot should enable them again.

Sorry for not giving you straight answers on how to fix it, but I really think it's ip-routing or firewalling.

Iowan
January 11th, 2010, 11:04 PM
On the routing front...
Check route -n - the last line should show your default gateway. That'd be it's window to the world. If it'd ping by address but not name, DNS would be a more likely starting point. MTU (my latest favorite villain) is still on-deck.

mnormand
January 12th, 2010, 12:37 AM
On the routing front...
Check route -n - the last line should show your default gateway. That'd be it's window to the world. If it'd ping by address but not name, DNS would be a more likely starting point. MTU (my latest favorite villain) is still on-deck.


how about this? that last line gateway is the router's ip address...



mn@mn-laptop:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0
mn@mn-laptop:~$