View Full Version : [ubuntu] Audio device is not detected

January 9th, 2010, 11:10 AM

I've been using Ubuntu for while now and my experience has been very good except on one front: management of audio devices. Trying to configure my audio cards (I have installed Ubuntu in 3 of my computers) is IMHO too complicated. Alsa Mixer, OSS, PulseAudio... I know I'm probably mixing apples and oranges but the lack of a simple way to configure my audio cards (almost all of them) has led me to a situation where I'm given all of these options and multiple choices of configurations for all of them. ufffff! my brain is about to explode.

Couldn't Linux for human beings distros make this a bit simpler for limited human beings like me (and 98% of other human beings)? :-)

Anyway, to make my story short, I need the help of the community to solve the most serious problem I have had to face on this front: now Ubuntu doesn't see any audio device. So I don't even have the choice of stressing over which possible combination of settings or use of Alsa, OSS or PulseAudio. Now it looks like I have no audio card.

Necessary info:

- I'm running Karmic Koala on a Pentium 4 machine.

- My computer has an integrated sound card and I'm using a USB audio card: Creative X-mod. After a lot of searching, I managed to get the USB card to work by disabling the integrated sound card in the BIOS. However, the sound was horrible because there was a noticeable hissing sound. When trying to solve the problem (see below for more info), I screwed up things totally and now no sound device is detected.

- Ask me for any other information you think you need to help me

The little speaker symbol that appears on the panel by default has been invisible for quite a while. I don't really remember when it happened. All of a sudden it was not there and I don't know what I did to make it disappear. When I go to System > Preferences > Sound > Hardware I don't see anything in 'choose a device to configure'.

Now, as I said, this wasn't always the case. Up to now the sound card was working even though it produced a horrible hissing sound. When I tried to configure it via System > Preferences > Sound > Hardware it only gave me options to set it as 4.1 or 5.1 speaker system but I have a 2.1 speaker system. With all the options available I got the hiss.

Searching through the net I saw some people claimed they had solved the problem by installing the OSS audio drivers. I did that and that's when **** happened. Now my system does not detect any device.

Can anybody help me out?

Josep M. A not so newby user.