PDA

View Full Version : [ubuntu] 9.10: Can't connect to wired network



ToddFisher
January 9th, 2010, 12:04 AM
Hi,

I just got wired internet access (to replace public wifi), but on my Aspire One running Ubuntu 9.10 it will not connect. My Dell running 8.04 works fine.

On 9.10, when I plug the ethernet cable in (before or after boot) the "auto eth0" pops up under wired networks in network manager. But if I click on it, it spins for a while, then it says "wired network disconnected". Wireless connection works just fine.

I've seen lots of complaints about this when I google it, but I don't understand the fix. Anyone solved this?

Thanks!
Todd

And a little extra info, tried running a couple things:

vale@m1:~$ sudo dhclient eth0
[sudo] password for vale:
Internet Systems Consortium DHCP Client V3.1.2
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:23:8b:0a:d2:fb
Sending on LPF/eth0/00:23:8b:0a:d2:fb
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
vale@m1:~$


vale@m1:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:23:8b:0a:d2:fb
inet6 addr: fe80::223:8bff:fe0a:d2fb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:131211 errors:0 dropped:0 overruns:0 frame:0
TX packets:79 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8129813 (8.1 MB) TX bytes:19721 (19.7 KB)
Interrupt:28 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1371 (1.3 KB) TX bytes:1371 (1.3 KB)

wlan0 Link encap:Ethernet HWaddr 00:23:4e:80:2c:31
inet addr:192.168.1.109 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::223:4eff:fe80:2c31/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9199 errors:0 dropped:0 overruns:0 frame:0
TX packets:10015 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7733590 (7.7 MB) TX bytes:1600627 (1.6 MB)

wmaster0 Link encap:UNSPEC HWaddr
00-23-4E-80-2C-31-38-30-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

garvinrick4
January 9th, 2010, 12:48 AM
It is not connected properly, check your wiring.

bkratz
January 9th, 2010, 01:37 AM
You might want to look at this thread

http://ubuntuforums.org/showthread.php?t=1156441

ToddFisher
January 9th, 2010, 01:44 AM
I wish it was that easy. If I plug the cable into my Dell, it works fine (in both Windows and Ubuntu 8.04). Plug it into the Acer with 9.10.....and no luck.

Iowan
January 9th, 2010, 05:16 AM
Try turning off the wireless - although my Jaunty laptop occasionally connects to both wired and wireless concurrently, Network Manager ordinarily manages only one device at a time.

ToddFisher
January 9th, 2010, 06:09 AM
No luck with either. Tried editing that dhclient.conf file, no difference. Tried turning off wireless, no luck. And it turns itself back on during reboot.

And interestingly, my Dell running 8.04 works wonderfully. I pull the cable out, it jumps to wifi. I plug it back in, it shuts down wifi. Makes me wonder - is 9.10 just not quite right yet? Or did Acer create a truely incompatible monster?

Thanks for the help! I really appreciate it. This is a great forum.

- Todd

Iowan
January 9th, 2010, 04:26 PM
Here (http://ubuntuforums.org/showpost.php?p=8602179&postcount=2) are a couple of options - one of which you've already seen/tried.

...although I suspect it's the /etc/dhcp3/dhclient.conf file instead of dhconfig.conf

ToddFisher
January 15th, 2010, 06:53 PM
No luck with that. I even tried copying that file from my 8.04 setup - which works fine - but no luck in 9.10.

But I did find a solution. Its a wireless router. =)

rayefrenzy
January 21st, 2010, 04:58 AM
Todd, let me know if you get a fix. I've got the same dang problem and I've tried all the "fixes" with no luck as well :\

Whats even more lame is I need my wired connection to get my wireless drivers... so I'm screwed in the interim here.

sportfreak2020
January 21st, 2010, 08:02 AM
i am no expert at this thing per se, but based on eth0's output it looks like its got the ipv6 address on but not the ipv4 one..

hmm...

well how about if you set the IP address manually through command line..just take up the most possible IP from your router and see what happens...

example: sudo ifconfig eth0 192.168.0.xxx

and then try ifconfig and see if it manually set an ipv4 address to the machine...

also another completely different shot would be under preferences in network connections..navigate to the eth0 and click on the edit button..
then select the IPV4 settings tab, and double check that it is DHCP over there and not other option before you do the above mentioned step.