View Full Version : [SOLVED] USR dial up modem NOT working on Ubuntu 9.10 (wubi)

January 8th, 2010, 08:20 PM
I just can't seem to get this thing going. I've also tried Gnome-ppp. Press detect and it says "no modem installed"
I did install it in Windows as well to make sure the darn thing actually works. It did perfectly.

Your US Robotics modem attached at /dev/ttyACM0
>>> The problemt: wvdial for some reason cannot use it

I had to edit the /etc/wvdial.conf file with gksudo gedit /etc/wvdial.conf

john@ubuntu:~$ sudo wvdial
[sudo] password for john:
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding.

I can see the data lights flashwhen sending. Gnome-ppp says "can't open modem"

john@ubuntu:~$ lsusb

Bus 001 Device 003: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 001 Device 002: ID 0baf:0303 U.S. Robotics
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

john@ubuntu:~$ dmesg

[ 149.192070] usb 1-1: new full speed USB device using uhci_hcd and address 3
[ 149.360927] usb 1-1: configuration #1 chosen from 1 choice
[ 149.859257] cdc_acm 1-1:1.0: ttyACM0: USB ACM device
[ 149.862438] usbcore: registered new interface driver cdc_acm
[ 149.862453] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters

January 9th, 2010, 12:15 AM
I had a thought. I didn't uninstall the builtin winmodem. Should I have? Could it be interfeering. USR says to first uninstall. Didn't affect Windows though.:redface:

January 9th, 2010, 04:11 PM
It took fore ever to find a confirmed bug in Ubuntu BUG#469881.

Uninstall moddemmanager & Gnome-ppp works like a charm.
I'm using it now.


January 10th, 2010, 03:09 AM
Jeez. One more reason to avoid 9.10. Ubuntu dial-up just keeps getting worse and worse with each release.