View Full Version : [ubuntu] I have to type "sudo modprobe ath5k" everytime I want to use my wireless card

January 7th, 2010, 09:08 PM
Hi everyone,

I upgraded to 9.10 on the day it was released, and since then, my wireless has given me nothing but problems on my laptop (been having to use Windows just for wireless).

I have finally managed to get it to the stage where I can at least use and connect via wireless by typing "sudo modprobe ath5k".

How can I get it to use this by default everytime Ubuntu loads up please?

I'm a Linux noob, but this seems like an easy fix to me.... I just don't know how to do it!

Thanks in advance.

January 8th, 2010, 07:26 PM
Not entirely sure what I did, but all is working now.
I followed these instructions, http://www.ubuntugeek.com/how-to-get-ath5k-working-on-jaunty-with-compat-wireless-and-a-self-compiled-kernel.html:

Sir Eliah says:
August 8, 2009 at 11:52 am

It works for Presario f755us with the same ethernet device. I compiled kernel and installed that compat-wireless and it seems to be ok.

There were only two problems: 1) it was necessary to type “sudo modprobe ath5k” every time after reboot, but I solved it by adding “ath5k” in file “/etc/modules”.
2) network-manager-gnome were a bit irritating constantly asking for a key to the key database or something, solved it by installing wicd. :D

Now wireless works excellent, thx for tutorial!

...but they didn't seem to work - only after the 2nd reboot of the laptop did I notice that the wireless was connecting again.

Just hope this helps anyone who has a similar problem.