View Full Version : [SOLVED] No rule to make target Drivers/rt73-k2wrlz-3.0.3/Module

January 7th, 2010, 10:45 AM

Am trying to install the rt73 drivers and am getting the following error message

make[1]: Entering directory `/usr/src/linux-headers-2.6.31-17-generic'
make[1]: *** No rule to make target `Drivers/rt73-k2wrlz-3.0.3/Module'. Stop.
make[1]: Leaving directory `/usr/src/linux-headers-2.6.31-17-generic'
rt73.ko failed to build!
make: *** [module] Error 1

Any ideas ?

Thought I had installed the linux headers properly but not sure.


Project PWNED
January 7th, 2010, 01:56 PM
I had that same problem yesterday and the TP-Link USB card I had ended up supporting injection out of the box, so I didn't mess with it further. Is this what you're trying to do?

January 8th, 2010, 12:59 PM
Yeah but my TPlink doesn't seem to do injection. Am on 9.10.

Perhaps I am doing something else wrong - but back to the question at hand .... how do I get the driver to compile ?

January 8th, 2010, 02:02 PM
Do you have the package build-essential installed? Please do so and try again.

January 9th, 2010, 06:39 AM
Yeah. Its installed. Seems like I have installed just about every header development and linux kernel package as well but am open to more suggestions.

January 9th, 2010, 07:21 AM
often folks are following a guide to help them install

can you tell us what guide you used please?

I installed the drivers for rt73 for a **** Smith USB wireless device

I posted what worked for me here


is anything here of use to you?

January 9th, 2010, 07:50 AM
I used tpark's guide in the following post although I have looked a a few others this is the primary one.


I guess the TPlink device should be the same as the **** Smith device given they are both rt73 based so I will try your instructions and see how they go...

Thanks for all your prompt help so far.

January 9th, 2010, 09:33 AM

Followed these instructions

Think my problem was I was just doing a make in the Module directory. When I used dkms to load it everything just worked. Device now injecting.

Thanks for all your help.