PDA

View Full Version : [ubuntu] 9.04 new install, no wired internet connection



MJY
January 7th, 2010, 02:47 AM
Problem: Can't connect to internet in FireFox via wired connection "AutoEth0" per networking menu.

PC Details ; IBM netvista PC.2002. 40 GB HD, 256 RAM, DSL wired connection via Ethernet card. Single partition new 9.04 install= all Ubuntu.

I have searched the forums and google for answers using various keyword searches. I have tried several suggested "tricks" , been through all the menus and tabs, and tried to follow what others have done. I am still stumped . The ethernet card appears to be working, but is the system seeing it as Eth0? Somehow disabled? Turned off? . I have a second PC running Ubuntu 8.04 (over 2 years now!) that has run great and wired connection simply worked after install. From other posts I ran some commands that others posted during similar trouble shooting. I used the output below and compared to 8.04 PC output looking for errors?...still stumped, but feel like I am learning something and want to get this 9.04 box connected instead of loading 8.04 hoping "that will work" as a solution! Trouble shooting command output from new 9.04 PC, follows...what am I missing???...TIA!

Edit : OK. after posting I have to figure out how to get all this code formatted correctly

mike@mike-desktop:~$ ifconfig eth0 Link encap:Ethernet HWaddr 00:09:6b:55:68:08 inet6 addr: fe80::209:6bff:fe55:6808/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:10 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:1836 (1.8 KB) lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:12 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:832 (832.0 B) TX bytes:832 (832.0 B)

mike@mike-desktop:~$ cat /etc/network/interfaces auto lo iface lo inet loopback

mike@mike-desktop:~$ sudo lshw -c network *-network description: Ethernet interface product: 82801DB PRO/100 VE (LOM) Ethernet Controller vendor: Intel Corporation physical id: 8 bus info: pci@0000:02:08.0 logical name: eth0 version: 81 serial: 00:09:6b:55:68:08 size: 10MB/s capacity: 100MB/s width: 32 bits clock: 33MHz capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.23-k6-NAPI duplex=half firmware=N/A latency=66 link=yes maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=10MB/s *-network DISABLED description: Ethernet interface physical id: 1 logical name: pan0 serial: 56:b4:9a:16:45:90 capabilities: ethernet physical configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

edit

manosx
January 7th, 2010, 02:57 AM
You don't have an IP
do
sudo dhclient eth0
what is ping www.google.com output then?
Do you connect to a router that gives you an IP automatically?

Iowan
January 7th, 2010, 03:01 AM
This (http://ubuntuforums.org/showthread.php?t=1156441) was an experience I had with Jaunty wired DHCP.

MJY
January 7th, 2010, 04:20 AM
Re: 9.04 new install, no wired internet connection
Edit : posted output
No I dont use a router, straight DSL modem connection. OK will try command and post output.

mike@mike-desktop:~$ sudo dhclient eth0


Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/


Listening on LPF/eth0/00:09:6b:55:68:08
Sending on LPF/eth0/00:09:6b:55:68:08
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
mike@mike-desktop:~$ ping www.google.com (http://www.google.com/)
ping: unknown host www.google.com (http://www.google.com/)

manosx
January 7th, 2010, 04:30 AM
Can you set your modem to act as a router?
If not, you need to dial from your linux box.
Have you tried doing it graphicaly from 'Network Connections' applet?
Right click on the applet and Edit Connections
Select DSL and Add
Any luck?

MJY
January 7th, 2010, 04:45 AM
Not sure if I can set my modem to act as router. Will ask Verizon. Also I have a router, maybe I'll set it up.
All part of the learning curve.
OK I follow you on > add > dsl >, will try that and post back 2morow.
I think I got spoiled with my 8.04 PC "that just worked" from the getgo.
I expected 9.04 to be a more robust release and act accordingly and the same.

Thanks for your help

manosx
January 7th, 2010, 04:50 AM
No problem
If that doesn't work you may also want to check running

pppoeconf
[https://help.ubuntu.com/community/ADSLPPPoE]
But as you can read in that guide:
"Warning: This guide is quite old now! Newer versions of Ubuntu use Network Manager (nice GUI) to manage DSL connections."