View Full Version : [SOLVED] Error in editing network connections

January 6th, 2010, 08:25 PM
I am using Karmic n loving it.
now i was trying to use opendns for my mobile internet connection.
So i got an article which says how to set the dns nameservers.
I right clicked and seleced edit connections from the network icon which shows up on the right side of the taksbar.(near the time and date).
and then i selected mobile broadband and thn clicked on edit, now at first i was able to edit the nameserver which was under ipv4.
But now after a reboot when i tried to go there by doing the same steps, whihc click on edit in the mobile broadband tab, i am asked for the password. I have the administrator password, so i tried it here.But no luck, it says error initializing editor and insufficient privileges.

January 6th, 2010, 11:57 PM
Is the administrator password different from yours? (Did you try yours?)

January 7th, 2010, 03:47 AM
actually for all the other things i'm using a password.
and here also i tried with that password.
for example i use this password for connecting to wireless networks, mounting windows partitions etc etc.
but still the same thing happens.. :(

January 8th, 2010, 12:04 AM
Which article? Did it use root or sudo? Can you use sudo at all? From a terminal does sudo ls work?

January 8th, 2010, 04:00 AM
yeah, sudo is just working fine.
as i said everything else is just working fine, i donno why this happens.
For all the other network adapters its working as exxpected. But for this mobile broadband thing, it says insufficient privileges.

Screen shots.
1. this happens when i try editing normal network connections/adapters.( it is working quite normal)

http://img340.imageshack.us/img340/5088/screenshotbf.th.png (http://img340.imageshack.us/i/screenshotbf.png/)

2. This is the problem I am facing. This happnes only with The specified connection. Mobile Broadband. But believe me, it was working 2 days back.
http://img138.imageshack.us/img138/4340/screenshot1t.th.png (http://img138.imageshack.us/i/screenshot1t.png/)

And one thing i see is, the error comes even before typing the password, which i didnt knw at first.

March 10th, 2010, 08:52 PM
I have the same problem, did you solve it?

March 11th, 2010, 05:38 AM
no man, i just uninstalled that application, and installed wicd, its far more better.. :D

March 14th, 2010, 09:37 PM
same problem

March 16th, 2010, 09:42 PM
Delete the connection which you can no longer edit.

Recreate it but this time...

Try leaving the checkbox "Available to all users" unchecked. Worked for me under Mobile Broadband. ;)