PDA

View Full Version : [SOLVED] Picky Wireless



chronos89
January 6th, 2010, 09:50 AM
Greetings all, first time poster. I recently moved to Beijing and am having trouble with my apartment's wireless setup. My laptop can connect to any wireless network I find out in Beijing but not our home network. My Roommate has a mac laptop and has no issues connecting to our wireless router. It appears to connect but receive no signal, which is frustrating me to no end. Here is my spec list and the model of wireless router we are using.

Pardon the extreme amount of info.

System information report, generated by Sysinfo: 06/01/2010 4:34:28 PM
http://sourceforge.net/projects/gsysinfo

SYSTEM INFORMATION
Running Ubuntu Linux, the Ubuntu 9.10 (karmic) release.
GNOME: 2.28.1 (Ubuntu 2009-11-03)
Kernel version: 2.6.31-16-generic (#53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009)
GCC: 4.4.1 (i486-linux-gnu)
Xorg: unknown (26 October 2009 05:15:02PM)
Hostname: chronos-laptop
Uptime: 0 days 1 h 38 min

CPU INFORMATION
GenuineIntel, Genuine Intel(R) CPU T2500 @ 2.00GHz
Number of CPUs: 2
CPU clock currently at 2000.000 MHz with 2048 KB cache
Numbering: family(6) model(14) stepping(8)
Bogomips: 3989.97
Flags: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc arch_perfmon bts pni monitor vmx est tm2 xtpr pdcm

MEMORY INFORMATION
Total memory: 3022 MB
Total swap: 8856 MB

STORAGE INFORMATION
SCSI device - scsi0
Vendor: ATA
Model: ST9320421AS
SCSI device - scsi1
Vendor: MATSHITA
Model: DVD-RAM UJ-841S

HARDWARE INFORMATION
MOTHERBOARD
Host bridge
Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
Subsystem: Toshiba America Info Systems Device ff10
PCI bridge(s)
Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
Intel Corporation 82801 Mobile PCI Bridge (rev e2) (prog-if 01)
USB controller(s)
Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02) (prog-if 20)
ISA bridge
Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
Subsystem: Toshiba America Info Systems Device ff10
IDE interface
Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02) (prog-if 80 [Master])
Subsystem: Toshiba America Info Systems Device ff10

GRAPHIC CARD
VGA controller
nVidia Corporation G73 [GeForce Go 7600] (rev a1)
Subsystem: Toshiba America Info Systems Device ff10

SOUND CARD
Multimedia controller
Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
Subsystem: Toshiba America Info Systems Device ff10

NETWORK
Network controller
Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
Subsystem: Intel Corporation Device 1040
Ethernet controller
Intel Corporation PRO/100 VE Network Connection (rev 02)
Subsystem: Toshiba America Info Systems Device ff10

NVIDIA GRAPHIC CARD INFORMATION
Model name: GeForce Go 7600
Card Type: PCI-E 16x
Video RAM: 256 MB
GPU Frequency: 450 MHz
Driver version: NVIDIA UNIX x86 Kernel Module 185.18.36 Fri Aug 14 17:18:04 PDT 2009

Also the wireless router we are using is a TP Link wr340g+
We have yet to secure the connection as the router page is in mandarin. I was able to find an English version of the guide online and will be working with it against the mandarin as the layout in the guide looks the same. Thank you for your time, hope to hear back from someone soon.

iponeverything
January 6th, 2010, 10:20 AM
Wireless channels and freq's very depending country.

So, your issue might be related to freq the wireless router is using. I am pretty sure that you change the country code for the card. If not you have to change channel/freq that router is using to something that is common to both devices.

Also, to navigate the menu in the router. Just open http://translate.google.com

And paste in the menu options.

chronos89
January 6th, 2010, 10:55 AM
How would I know which channel I should be using and how would I go about changing my country code for my wireless card? I'm quite familiar now with Ubuntu after using it for about 6 months but I'm not very verse with figuring out networking on it. I have experience using routers pages and configuring some network settings in windows. However I have never needed to fiddle around with networking on linux until now. Again any help given is extremely appreciated, I'm sick of my mac user roommate mocking me :P

iponeverything
January 6th, 2010, 11:44 AM
Find out what module your using:


lshw -c network

Locate the block for wireless and look for something like:


configuration: broadcast=yes driver=ath_pci ip=10.111.111.111 latency=168 maxlatency=28 mingnt=10 module=ath_pci multicast=yes wireless=IEEE 802.11g


driver=

will be the the module your using, look here for specifics for changing the country code for your specific card:

http://wiki.archlinux.org/index.php/Wireless_Setup

chronos89
January 7th, 2010, 02:18 AM
Thank's ipone for all of your help. The problem was simpler, I changed the channel on the wireless router page and it worked like a charm.