View Full Version : [ubuntu] Can ping but no internet access

January 6th, 2010, 12:55 AM
I have a Compaq Presario R3000 with Ubuntu 9.10 32 bit that I just installed last night. I'm using a Zyxel G-102 Wireless card and Actiontec GT701WG wireless modem.

When I try to connect to the 'net, the network does show up and it connects strong (100%). It also shows multiple neighbors networks. It pings at 99% success (with over 900 sent as I write this) but when I open Firefox it can't connect, it just times out. I've used WEP security and have switched off security as well. I tried hooking up to the modem via USB and get the same result. It acts like a Firewall issue but there isn't one installed - at least that I can find and the Firewall in the modem is off. I ran FF in root with gksu firefox as suggested in another thread. I tried www.ubuntu.com (http://www.ubuntu.com) and the header loaded but that was all. Then it timed out.

I'm new to Linux but have used Puppy Linux with this machine and card, etc. so I know it can/does work with Linux. I wanted a more refined distro and chose Ubuntu.

I know I have to be close but it's driving me nuts. Any help is greatly appreciated.


January 6th, 2010, 03:18 AM
Check route -n to verify the gateway, and look for valid nameservers in /etc/resolv.conf.

January 7th, 2010, 03:27 AM
Thanks for the help. Here's the results:

/etc/resolv.conf. returns No such file or directory

route -n returns:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 2 0 0 wlanl U 1000 0 0 wlanl UG 0 0 0 wlanl

January 7th, 2010, 03:37 AM
Oops... punctuation got in the way. Try it as:
cat /etc/resolv.conf

January 7th, 2010, 03:57 AM
That one worked. cat /etc/resolv.conf returned:

# Generated by NetworkManager
domain domain.actdsltmp
search domain.actdsltmp

Just an FYI - Don't know if it helps but the 216.229.32. nameserver is correct for my ISP.

Thank you.

January 7th, 2010, 11:59 PM
I've seen other threads where the problem was solved by tweaking the MTU (via ifconfig). 1492 seems to be a familiar number.

I used this in another thread - pardon the cut/paste answer... but maybe it'll help.

January 8th, 2010, 04:18 AM
Thanks Iowan, I'll monkey around with that. Oddly enough I hooked it up via the Ethernet cable and started Firefox. It did the same, showed connected but timed out. But then an Update Manager window popped up and said Updates are ready for your computer. I clicked ok and it proceeded to download a bunch of updates. 113 of them I think. BUT, even while the connection was active with the download I tried Firefox again and got nothing. Rebooted and no difference.
I'll try your suggestion and let you know if it works.

January 8th, 2010, 04:50 AM
Hey there,

If you suspect it to be an MTU issue, you can verify this with ping. Do the following:

ping -s 1600 www.google.com

ping -s 32 www.google.com

What we're doing is setting the size of the ICMP packets we're sending out. If they're outside the scope of what a functional MTU is you won't get a response. For example, if your MTU is currently too high, the 32 should respond fine, but 1600 shouldn't and vice versa.

If both come back fine (as 1300 - 1600 are standard mtu sizes) then it's an issue above layer three and we would have to start looking at application specific issues as well as protocol issues. Are you able to do the following from terminal?

cd ~/Desktop & wget www.google.com

If it downloads, it means that standard http traffic is forwarding for you and the issue might actually just be firefox.

January 8th, 2010, 11:59 PM
The 1600 result was -
PING www.google.com (http://www.google.com) ( 1600 ( 1628 ) bytes of data.

The 32 result was -
40 bytes from www.google.com (http://www.google.com) ( icmp_seq=1 ttl=50 time=70.2 ms
and it just kept counting up with each return

The cd ~/Desktop & wget www.google.com (http://www.google.com) returned -

[1] 1838
--2010-01-08 15:50:22-- http://www.google.com/
Resolving www.google.com (http://www.google.com)...
Connecting to www.google.com|:80...failed: (http://www.google.com%7C:80...failed:) Connection timed out.

retrying got the same result.

August 28th, 2010, 04:51 AM
this is exactly the same trouble I'm having: I can ping but everything else times out. I've not done anything different in the last few days, and until today everything was fine.

I'll have a look around and see if there is anything which may solve this issue.

September 18th, 2010, 08:21 AM
Does the Synaptic Package Manager (System>Administration) show that you have updates to install? If yes, download and install the updates.
Also try browsing using an alternate browser.

September 18th, 2010, 10:18 AM
Try the steps from post #15 on this link.

September 18th, 2010, 10:54 AM
Posted as new thread