PDA

View Full Version : [ubuntu] dhcp problem



isahak
January 5th, 2010, 09:47 AM
Hi Everyone

I have five computers. So, 2 ubuntus, 1 xubuntu, 2 windows. I have set a dhcp pool on a cisco router/switch. Now, whenever I connect the windows machines to the router, they get the ip addresses automatically. However, the ubuntu machine does not get an ip address. If I look at the light on the Ethernet port on the router, For ubuntu it shows nothing. but for the windows the light is always on.

However, if I manually give an ip address to the ubuntu machine, and try to ping the router it works. So I believe that, something in my ubuntu box is stopping it to get an ip address automatically. I am really confused.

Any help would be appreciated.

pedro_orange
January 5th, 2010, 10:26 AM
What does network-manager say? (Top right hand corner)

Do you have eth0 enabled? Is it set to ask for DHCP?

What kind of switch do you have? Does it have a built-in DHCP server? A switch is not a router :)
A switch will provide connectivity providing they are in the same network, but it will not route packets like a router.

If you have another machine acting as a DHCP server that's fine, but you need to tell the Ubuntu box that the machine is the DHCP server.

What IP Addresses are the Windows boxes getting? Are they the 169 addresses? These are given by Windows when they cannot obtain an IP address from the DHCP server.

pedro_orange
January 5th, 2010, 11:29 AM
Right, so it gets an IP address if you plug it directly into the router. That's good. There is nothing wrong with the driver, or the card.

What you need to do is tell eth0 that the DHCP server is your router. You can do this from the network-manager plug-in iirc.

It could well be a firewall issue, but unless you've installed something like Firestarter - I doubt it is.

isahak
January 5th, 2010, 11:31 AM
what does network-manager say? (top right hand corner)


do you have eth0 enabled? Is it set to ask for dhcp?

yup it is set to dhcp. If i connect the ubuntu pc to my d-link router(i have internet on this one), it gets an ip address.


what kind of switch do you have? Does it have a built-in dhcp server? A switch is not a router :)

sorry, i should have mentioned, that at first i connected one of the ubuntu pc, and then windows pc to the router. Then i did the same thing to a switch. The switch is connected to a router.

And yes there is a dhcp server in the router, i have a dhcp pool on that.:p



if you have another machine acting as a dhcp server that's fine, but you need to tell the ubuntu box that the machine is the dhcp server.

no the router is acting as a dhcp server.


what ip addresses are the windows boxes getting? Are they the 169 addresses? These are given by windows when they cannot obtain an ip address from the dhcp server.

nope. They are not those addresses.

The router's fastethernet0/0 has 10.1.8.1

and the windows pc automatically gets the ip address 10.1.8.2



i remember, i read somewhere, that i need to disable, some firewall setting on ubuntu. But now i could not find all those instructions. So, can anyone help?


:p:p

isahak
January 5th, 2010, 11:34 AM
Right, so it gets an IP address if you plug it directly into the router. That's good. There is nothing wrong with the driver, or the card.

What you need to do is tell eth0 that the DHCP server is your router. You can do this from the network-manager plug-in iirc.

It could well be a firewall issue, but unless you've installed something like Firestarter - I doubt it is.

I can see that the firestarter is not installed.

pedro_orange
January 5th, 2010, 11:35 AM
Well set your connection's DHCP server to be the router

Iowan
January 6th, 2010, 01:55 AM
This (http://ubuntuforums.org/showpost.php?p=8602179&postcount=2) lists a couple of options.