PDA

View Full Version : [ubuntu] Samba folders dissappearing



caleb2003
January 3rd, 2010, 11:43 AM
Hi I keep having failures with samba mainly that each day the /var/run/samba folder seems to dissapear so Samba doesn't start, normally I can just add the folder back and samba will start and work ok but today it fails.

Does anyone know why this folder may just dissapear and if there is something I can do to get Samba working?

Thanks

dmizer
January 3rd, 2010, 03:17 PM
Hi I keep having failures with samba mainly that each day the /var/run/samba folder seems to dissapear so Samba doesn't start, normally I can just add the folder back and samba will start and work ok but today it fails.

Does anyone know why this folder may just dissapear and if there is something I can do to get Samba working?

Thanks

Exactly what folder disappears, from where, and exactly how do you add it back in?

Include screenshots if necessary. :)

caleb2003
January 4th, 2010, 01:10 AM
Exactly what folder disappears, from where, and exactly how do you add it back in?

Include screenshots if necessary. :)


Hi, the /var/run/samba folder is the one that dissapears I attached a screenshot of what i then did here http://yfrog.com/18screenshot1rip I added the folder back but starting samba just fails.

caleb2003
January 4th, 2010, 02:23 AM
Also I need to add that in var/log/samba there is nothing in the samba log file since 13/12/09 even though I used samba only 3 days ago (I mainly shgare to an original xbox)
the log.winbindd and log.smbd are there though the log.nmbd for instance has this in:
[2010/01/03 20:24:42, 0] nmbd/nmbd_become_lmb.c:395(become_local_master_stage2)
*****

Samba name server MAINPCLINUX is now a local master browser for workgroup MSHOME on subnet 192.168.0.4

*****
[2010/01/04 00:57:27, 0] nmbd/nmbd.c:71(terminate)
Got SIGTERM: going down...

caleb2003
January 9th, 2010, 12:04 PM
Did a full reinstall of samba and it worked great but once again after reboot something has deleted my /var/run/samba folder, Anyone got any ideas?

Please!

dmizer
January 9th, 2010, 03:01 PM
I am still not sure what your problem could be, or could be related to.

Please post your /etc/samba/smb.conf file.

Edit:
No ...

You need to start the samba server with root permissions. Try this instead:

sudo /etc/init.d/samba start

caleb2003
January 9th, 2010, 03:17 PM
Hi, thanks that does indeed start samba succesfully and I can see the shares from other PCs although there is one share I cannot see and maybe it is this that is the problem.
My pc is partitioned with Windows and Ubuntu and I am sharing a folder from the windows partition via Ubuntu but this has actually stopped sharing this particular folder as well and it also has done it this time too.

It seems to be related to this but I don't know why?

dmizer
January 9th, 2010, 05:48 PM
It seems to be related to this but I don't know why?

Yes, this is related. Here is a thread in which that issue was resolved. It includes directions on how the problem was resolved as well: http://ubuntuforums.org/showthread.php?t=1367919