View Full Version : [all variants] The battle for Ubuntu...long story. problems with ntfs partitions at the end

January 3rd, 2010, 08:33 AM
Sorry, its a bit of a story, but worth the read.

First off, i would like to say hello. i am very new to linux, and am probably at best a weekend warrior type computer person. i know enough to know that i am completely dissatisfied with windows and i can figure most things out if i have to. a friend of mine has used ubuntu on a few of his machines and i figured that should be the starting point for my adventures. i do have some problems that i would like some advice on, but i feel i should share my story up to this point. i got the idea to switch to ubuntu on thursday after a day of struggling with my XP machine at work.

my machine at home is an AMD64 3800+ system with nothing special. i had been running xp pro with two partitions on the 250g hard drive. the first, was a 20g ntfs that had the os on it, the remaining 220ish gigs were in an ntfs partition with all my data on it (about 115g's full). for me, the choice was to just get rid of xp all together and run just ubuntu. i started by downloading the latest ubuntu file, 9.10. i followed the directions from the website as far as burning the disk, but i didnt think to burn it at anything other than full speed. i popped it in the maching and booted up with it, and started installing it. i just wiped the 20g XP drive and split that into the following partitions: a 2g swap, 10g "/", and about 8-9 gigs in a "/home" partition. the installation got to about 27% and then an error popped up saying i was missing a file on the ubuntu iso. at this point, i cannot load into an xp partition that no longer exists, and all i have is an iso that is on the other large ntfs partition. i feel like the best option is to re burn the iso at a lower speed and try again. but the problem is i cannot burn a cd from the live session because i only have 1 cd rom. so i decide that the next step is to kill the 3 half finished ubuntu partitions i have started, and re-install xp to burn a cd that will help me get rid of xp. its kind of ironic when you think about it.

anways, i try that and all of the sudden, since i have messed with the boot table, the hard drive will just simply not take windows anymore. i tried it with 3 different xp disks, all with the same result. i can get to the step when windows is loading all the files from the cd to the hard drive, and it needs to reboot to keep going. it reboots and then just hangs on the screen when you can press any key to boot from cd or let it load from the HD and continue to load xp. i have tried this at least half a dozen times trying different combinations of things, all with the same result. so i am stuck. i can load into ubuntu live from the cd, but i cannot install from the cd. i also cannot burn a cd while in live because the cd rom is occupied by the live cd. i do not have any thumb drives or anything like that, and i do not want to wait to get this resolved. did i mention that this is new years eve and nothing is open to buy a flash drive even if i wanted to? i also do not have any other computers to help me with this install. so i am stuck, but i get the idea to see if my JVC camcorder will work as a flask drive, after all it has a 30g hard drive and an SD slot that had a 1g card in it. i could not get the SD card to take the iso, the format was not correct and it would simply not work. i did however manage to get the 30g hard drive to take it without corrupting any of the video files that are currently on it. after booting up with my camcorder, which is quite the process let me tell you, it takes quite the combination of key strokes and button pushes around the time that bios is loading. anyways, it will boot into a live session off the camcorder, and so i just try and install ubuntu right there, off the camcorders HD. well, i get about 50% then it tells me that i am still missing a file and setup cannot continue. now it has me thinking that the file i downloading in the first place is corrupt and i need to start over from scratch. so i try and down load it again, but i do not have enough free space anywhere to down load it to and i cannot seem to get it to download the file the ntfs partition i have that has 100g's free. anways, after struggling with this for about a day in this state i just try and burn the iso again using a file i think is corrupt just hoping that somehow it will work this time. it doesnt. i burn another copy, that doesnt work either. i burned it a third time and then i got a live cd that would boot, and would install ubuntu without missing files. wow, what a battle. i have been struggling with this for days now, i have probably installed ubuntu at least 5 times, installed (or tried) windows at least 5 times, and was for awhile dependent on my camcorder to be able to get into a live session just to figure out what to do next.

so at this point, i have a successful install of ubuntu, but i need to get my data off my backup partition (the 220ish gig one). my goal is to put everything into my home partition, which would get resized to have all the space that the current ntfs one takes up. i have been at the stage for at least a day trying to do this all day. the biggest problem i have is that i have to do everything from linux, as i cannot get xp to load at all. and so far all i have done is either mess up the sectors on the partition, or simply get nothing done at all. i can get to the repair console using an xp cd, and i have had to use chkdsk /r twice to repair damage that the linux programs have done to the partition. the way i have it currently configired is with a 2 gig swap, 4 gig "/" partition, and about 15 gigs in the "/home" partition. i have transfered over as much as i can, having to be very selective about what i am backing up in case i have to just format the 220g partition. i have a few hundred mb's left on the home partition, but still about 105g's of stuff i would like to keep on the ntfs partition. i've got about 110g's of free space on the partition and i would like to resize it to about 106g, adding the remaining 109g's that was free to the home partition. this will give me enough space to get the remaining files (mostly music and movies) onto the home partition, which will allow me to delete the ntfs partition and redistribute the remaining free space to the "/" and "/home" partitions. i want to eventually have about 10-20 gigs in the "/" and everything else in the home partition.

this is where i am at, i cannot get any of the linux programs to work with the ntfs partition. i have tried gnome, gparted, and parted magic 4.8, all from live cd's. nothing will touch the partition. the last thing that i tried, which was the parted magic, it says something to the effect that the cylinders were too large, or too many, something like 1088>1024. i dont know if the problem is the partition is too big to deal with, or because gparted caused an error when it tried to format it the first time, and it cannot deal with the error. either way, i have had to try and fix the partition with chkdsk from the repair console (the closest i can get to windows) twice because of what the linux programs have done to it. i have no other way to back up this data other than to try and resize the partition to redistribute the free space to a linux partition. about the only thing i think i could do but dont want to do is burn 25+ dvd's with the data on them. is there something i am missing, or something i can do to get my 100g's of info saved onto an ext4 partition intact? something that will make parted magic work? i'm smart, but i'm still learning a lot about this level of technicality as far as windows and linux, so there is probably a lot that i just dont know about. please steer me in the right direction.

January 3rd, 2010, 11:27 PM
anyone have any help?