PDA

View Full Version : [ubuntu] ubuntu on virtual box won't boot (screen shots attached)



new lin
January 1st, 2010, 01:56 PM
Aftre upgading VirtualBox to 3.1.2 I faced this problem and ubuntu will not boot

what is the prolem & how to resolve my system

gsmanners
January 2nd, 2010, 02:09 AM
Some kind of weird new bug? Anyway, if that was a real system you could just recover grub's config with a live CD. If you still have the live CD around or an image of it, you could try that:

https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows

new lin
January 2nd, 2010, 05:01 AM
Thanks for your reply

What do you mean by real system ?

It's a single OS on a virtual machine (Sun Virtual Box running within MS Vista)

gsmanners
January 2nd, 2010, 01:31 PM
*If* it was a real system. Since it's a virtual system, you'll need to mount the Live CD using VirtualBox's configuration, but otherwise it's the same idea.

new lin
January 3rd, 2010, 02:14 PM
Thanks again

I did, but mount command asks about file system!

CharlesA
January 3rd, 2010, 02:36 PM
Thanks again

I did, but mount command asks about file system!

If the ISO is mounted in VirtualBox, then it should behave exactly like a cd in a cdrom. Being mounted at /media/cdrom.

new lin
January 3rd, 2010, 09:08 PM
If the ISO is mounted in VirtualBox, then it should behave exactly like a cd in a cdrom. Being mounted at /media/cdrom.


that.s right !

but trying to execute commands adviced to resolve the problem by mounting the root mount asks for file system

I tried to execute this :

mount /dev/sda1 /media/root!