PDA

View Full Version : [ubuntu] 9.10 Karmic Koala Using r128 video driver



sh00t
December 29th, 2009, 06:11 PM
Ubuntu 9.10
ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS

Hi! I'm running ubuntu 9.10 and just got an acer X223W LCD Monitor and my System>Preferences>Display only gives me 4 resolutions to choose from with 800x600 (4:3) being the highest.

Since I have no xorg.conf file how can I use the r128 driver...or do i need to generate xorg.conf?
The only experience I have with that has been ....painful... to say the least........

Here's info from compiz-check, as you can see ubuntu isn't using
the r128 driver..

./compiz-check



Gathering information about your system...

Distribution: Ubuntu 9.10
Desktop environment: GNOME
Graphics chip: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS
Driver in use: ati
Rendering method: AIGLX

Checking if it's possible to run Compiz on your system...

Checking for texture_from_pixmap... [ OK ]
Checking for non power of two support... [FAIL]
Checking for composite extension... [ OK ]
Checking for FBConfig... [ OK ]
Checking for hardware/setup problems... [ OK ]

lspci | grep VGA


01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS

sh00t
December 31st, 2009, 04:16 AM
K, so I made a xorg.conf file and am able to get 1024x768 refresh rate is 75 Hz but I'd like to be able to get 1680x1050 resolution...
Anyone got any pointers on that?

Here's my xorg.conf file if you wanted to take a look at it.....

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
#Option "UseFBDev" "true"
Option "CCEusecTimeout" "100000"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30-80
VertRefresh 55-75
ModeLine "1680x1050_60.00" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
DefaultDepth 24
Subsection "Display"
Modes "1680X1050" "1280X800" "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "Module"
Disable "dri"
EndSection