View Full Version : [ubuntu] All embedded video lags in Firefox

December 28th, 2009, 08:52 PM

Im running Ubuntu 9.04 (Jaunty), with Firefox 3.0.16.

All embedded videos that I find on the internet (e.g. youtube, metacafe, etc.) lags. Some lag just enough for me to notice it, and some lag enough to make it look like a slideshow. Some videos on Youtube wont play at all, there is just a black rectangle instead of the player, while most at Youtube will. Most videos pixelize a bit when playing, and if I jump back (reverse) its all just a few big colored rectangles, untill I jump forward again.

DivX movies and all other movies I have had my hands on play perfectly well in VLC.

All the embedded content plays perfectly when I use Windows on the same computer (and even much older computers), so I do not think my hardware is insufficient.

I do not remember exactly how I installed Flash since it is a while ago, but I think Firefox suggested me 4 different plugins, and I chose the one from Adobe. This means that I have not installed anything myself (as far as I remember). This did not work with my previous version of Ubuntu (think it was 8.04), but with 9.04 this service seemed to work. Except for the problems described above.

How can I fix this?

My setup:
Acer Travelmate C300
Celeron Mobile 1.5GHz (32bit)
1280 mb ram
Video card: Intel, 82852/855GM Integrated Graphics Device

Your help is greatly appreciated, since I really depend on some online courses, and I'm getting really tired of rebooting into Windows constantly.


April 5th, 2011, 10:54 PM
I have the same problem. If I open several tabs with flash in them, the flash plug-in crashes and I have to refresh the page. So temped to go chromium.