View Full Version : [xubuntu] 9.10 Diskless boot

December 28th, 2009, 01:37 PM
Dear All,
I run an installation of some diskless clients.

They are currently using Xubuntu 8.04 and it is working great.

Since Xubuntu 9.10 really seems to be faster, I have tried to get it working in parallel, but I cannot get it to boot. Here is what I have done:

Installed Xubuntu 9.10 on hard disk
Copied files from installation into server
Changed initramfs.conf (modules=netboot and root=nfs)
chrooted in and ran update-initramfs
Copied vmlinux and initramfs into my tftp server

So... the 2.6.31-16 kernel boots (NFS root exported rw for testing), does its apparmor setup, sets up preliminary keyboard map and stops... any ideas?


January 15th, 2010, 04:30 PM
same issue here, since upgrade to 9.10 boot fails, after apparmor profile loading. there are no error messages shown :(

May 1st, 2010, 08:16 PM
Exact same issue here. Worked fine in 9.04, stopped working in 9.10 and still does not work in 10.04!

I believe the issue is actually it is having problems finding the NFS root. If you wait for 2 minutes you should see a timeout message.

May 1st, 2010, 08:57 PM
I managed to fix it. I had to edit the file '/etc/network/interfaces' on the diskless root and set it to:

auto lo
iface lo inet loopback

iface eth0 inet manual

The last line is what I added, and it is needed so that network manager doesn't break the interface. Without this, the network actually goes down and thus you can't access the NFS root.