PDA

View Full Version : [ubuntu] Screen divided to three parts, when playing a movie



valexi
December 27th, 2009, 09:21 PM
When I am playing a movie, it seems that some codec or something flickers the image. Sometimes I see, when they get somehow out of sync and I see the lines, where they are.

This happens with XBMC and also with MPlayer. What could cause this? I'll try to add screenshots later.

CPU: Intel C2D E6400
GPU: GeForce 9400 GT
2GT RAM, 800mhz

These shouldn't be the bottleneck, when playing 1080p mkv files?

I'm using Karmic 9.10 and latest NVIDIA drivers.

valexi
December 29th, 2009, 10:38 AM
I have tried to take a screenshot from it, but when this error appears and I stop the image, the error is gone.

Could this be a problem with 24p movies TV's refresh rate missmatch? I have ubuntu set on 1080p/24hz resolution, but this doesn't seem to affect on XBMC nor MPlayer.

Any clues?

valexi
December 31st, 2009, 03:31 PM
Now I managed to record this thru digital camera. Here is the video:

http://tinypic.com/player.php?v=2946o2q&s=6

valexi
December 31st, 2009, 05:06 PM
I GOT IT WORKING! This error is called "Video Tearing" and this is how I fixed it:

Edit /etc/rc.local file:


sudo nano /etc/rc.localAdd this before part: "exit 0":


chmod 666 /dev/nvidia* &Then edit xorg.conf


sudo nano /etc/X11/xorg.confAdd these lines there. DRI is for Direct Rendering:


Section "DRI"
Mode 0666
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
Load "dbe"
EndSectionThen open NVIDIA settings: System -> Administration -> NVIDIA X Server Settings:
X Server XVideo Settings -> Check box for Sync to VBlank
OpenGL Settings -> Check box for Sync to VBlank

Then Quit NVIDIA Settings and reboot Linux. If you still see Tearing try this:

System -> Preferences -> Appearance
Open Tab: Visual Effects
And check: None


This fixed Video Tearing problems for me!