View Full Version : [all variants] turn off mouse cursor

December 23rd, 2009, 07:47 PM
Can anyone tell me how I can disable the mouse cursor in x.org?

I have a media pc (xbmc) that I only use the remote and keyboard on (although the keyboard receiver has mouse support, and a mouse I don't use it) and I want to stop the cursor appearing.

Initially the mouse cursor is hidden, but if I resume from suspend the cursor appears in the middle of the screen and only goes away with a reboot.

I'm running 9.04 with nvidia drivers.

December 23rd, 2009, 08:13 PM
There is an applet to lock mouse in to it. It is available in 9.04 not in 9.10.

December 23rd, 2009, 09:05 PM
I have seen that, however I'm not using gnome so I'm not sure it's any use to me in this instance (used it for a while on my work system, it can be quite handy).

In this instance I'm loading X with no window manager, and launching xbmc from .xsession

December 23rd, 2009, 09:31 PM
I suppose it is a bug. Try to monitor this:

December 23rd, 2009, 09:58 PM
I believe that is related to the issue I'm seeing, and I saw someone say that they think it's to do with SDL not knowing how to handle the mouse properly when coming out of suspend.

That makes sende to me Fixing that is fine if you want to keep and use the mouse.

However I don't want to use the mouse ever and I figured there might be an xorg.conf switch I don't know about (or maybe an nvidia driver option) that would allow turning off of the mouse cursor at the x window level rather than the application level.

December 23rd, 2009, 10:21 PM
This is describing a way to have a dummy mouse in xorg.conf

It is for a touch screen, I don't know if it make dummy also your keyboard....

In any case here is a detailed explanation on xorg.conf parameters:

December 23rd, 2009, 10:45 PM
ooh that's interesting, I'll give that a try.