View Full Version : [ubuntu] Sound Preferences Problem

December 23rd, 2009, 12:09 PM
I've got an unusual problem with 9.10 (2.6.31-16 kernel), not sure if it happened on older kernel.

Whenever I boot into Karmic non of my sound will work at all. I have to go to sound preferences, switch to Analog output from Digital, and then back again. I've used the update manager as of a few days ago to fully update everything (ISP having issues so can't check if there are more updates).

I'm using a Realtek onboard system (Motherboard is a Gigabyte GA-P35-DS3).

Any idea's how to fix this so I don't have to keep switching my sound output back and forth everytime I reboot. This is one of my last 2 nickling annoyances preventing me switching to using Ubuntu as my primary desktop. :(

December 23rd, 2009, 01:53 PM
...you might have missed some codecs, install the ubuntu-restricted-extras

December 23rd, 2009, 02:02 PM
I've already gotten the codecs.

I load up and my output is set to digital. Sound doesn't play. These are the steps I do to make it work...

1) Go into sound preferences
2) Switch to analog output
3) Apply
4) Switch back to digital
5) Apply

And now sound works.

The thing is I have to do this every single time I boot up.

December 26th, 2009, 02:01 PM
...hope you get something from this: