PDA

View Full Version : [ubuntu] AWN and Screenlets question in Kde desktop...



Struki
December 22nd, 2009, 01:03 AM
I'm running ubuntu but I wanna try out kde enviroment, so I installed kubuntu desktop. When I switch to kde AWN and all the widgets load up and they overlap with my kde panels so I was wondering is there a way to stop them from running in kde but still keep them running in gnome.

Andysan
December 25th, 2009, 01:11 AM
I too would be interested in a solution to this please!

Cheers,

Andy

Andysan
December 30th, 2009, 10:39 PM
I've knocked together what I think is a solution to this.

Copy and paste the following into a text file, name it whatever you like. I called mine awnscript.sh. Then make it executable (chmod x awnscript.sh) and copy to /usr/bin. Finally, click System>Preferences>Startup Applications and change the entry for AWN to point at the bash file.


#A bash file to launch awn only if the desktop environment is GNOME
#By Andrew Fletcher
MYPROCESS='gnome-session'

#if gnome-session running
if ps ax | grep -v grep | grep $MYPROCESS > /dev/null
then
#launch awn
awn
fi

pritamps
December 31st, 2009, 02:05 AM
You could go to ~/.config/autostart

And in the file awn.desktop, add this line


OnlyShowIn=GNOME;

This will make sure this only loads in Gnome...Do the same for the other files as well, of course. NotShowIn=KDE; will work as well.

Andysan
December 31st, 2009, 02:18 AM
You could go to ~/.config/autostart

And in the file awn.desktop, add this line


OnlyShowIn=GNOME;

This will make sure this only loads in Gnome...Do the same for the other files as well, of course. NotShowIn=KDE; will work as well.

Hey thanks, thats a much better solution!:guitar:

pritamps
December 31st, 2009, 04:52 AM
Well, I got it off the forums a year back I think :P

demontranoth
December 2nd, 2010, 07:43 PM
how do I edit the .desktop files?