View Full Version : [ubuntu] Samba disk not connected with Karmic

December 15th, 2009, 09:56 PM
Hallo I am brand new of this forum.
I have an external disk I perfectly read with jaunty. I use with two partition, one for music named "varie", and the other one for backups named "disco_backup".
The fstab file is like this:
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=6d4205f3-f594-4343-9e5e-3d3a71027cd9 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda2 during installation
UUID=14e82894-825b-40a1-a8de-d70ce5720d05 none swap sw 0 0
/dev/sda3 /home ext3 rw,defaults 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
# Disco esterno
// /media/disco_backup cifs credentials=/etc/samba/user,noexec 0 0
// /media/varie cifs credentials=/etc/samba/user,noexec 0 0
#Telefonino Nokia 6234
obexfs#-u1 /media/Nokia fuse noauto,user,fsname=obexfs#-u1 0 0
#Installazione Guest Additions per VirtualBox
none /proc/bus/usb usbfs devgid=125,devmode=664 0 0

Moved to Karmic, same fstab: no way to see the disk.
I was forced to go back to jaunty and it's weeks I am trying karmic with VirtualBox but with no success. I am a little bit frustrated. Thanks for yr help.

December 19th, 2009, 01:14 PM
Nobody can help me?

December 19th, 2009, 01:38 PM
Check the network configuration of your Karmic virtual machine in VirtualBox and switch from NAT to Bridge mode. If NAT mode is selected, you will have a lot of problems of communication with other machines of your LAN.

Best regards,


December 19th, 2009, 01:49 PM
I think quite a few people had or are having problems with samba in karmic.

A good source for help with sambe is this thread:

December 24th, 2009, 09:41 AM
Thank you for yr support. Unfortunately I did not fix the issue.
@Luis : I tried using Bridge mode setting in my VB Karmic; with "sudo mount -a" I receved back "Network unreacheable"; when set NAT, network is perfectly seen.

@Michael: I tried all the instructions of the link you added; by the way some of them were already in. Again no success.

I checked again all setting in my standard jaunty environment and in Karmic one and everything is the same (fstab, smb.conf, nsswitch.conf): in Jaunty run smoothly, in Karmic I can't see anything....

If somebody discovers something which solves pls help me, I will stay tuned!


December 24th, 2009, 12:48 PM
Sorry, my previous post is wrong. It belongs to another thread.

December 24th, 2009, 01:32 PM
Hi Paolo,

Please, follow this steps in order to identify your problem.

First step: try checking the communications with the CIFS file server:

Second step: check if the two mounting points /media/disco_backup and /media/varie exist:

ls -l /media
Third step: verify (with Synaptic) that the smbfs package is installed.

Fourth step: try to access to the shared directories using the command smbclient

smbclient -U your_samba_user //
The command will ask for your passwd. If you get a prompt similar to smb: \> the test is good. Type dir and quit .

Repeat the test with the other directory:

smbclient -U your_samba_user //
Fifth step: try to mount manually your directories:

sudo mount -t cifs // /media/disco_backup -o username=your_username,password=your_passwd,iochar set=utf8,file_mode=0777,dir_mode=0777
sudo mount -t cifs // /media/varie -o username=your_username,password=your_passwd,iochar set=utf8,file_mode=0777,dir_mode=0777
Last step: check if the file /etc/samba/user exists and if its content is good.

Follow theses steps until you get some kind of error and post the results.

Best regards and Merry Christmas,


December 24th, 2009, 04:20 PM
Thank you Luis. I tried everything you posted, I cannot say it works but something interesting arose.

ping: OK, I stopped the process after abt. 1000 chunks of 64 bytes correctly exchanged.

the two mounting points /media/disco_backup and /media/varie exist.
smb: I can reach smb: \> prompt. One thing more: when I type "dir" I receive:

smb: \> dir
. D 0 Wed Dec 31 23:59:59 1969
.. D 0 Wed Dec 31 23:59:59 1969
Ciajvkoskij.pdf A 34625 Tue Dec 28 09:25:12 2010
Musica D 0 Sun Nov 30 08:14:48 1986
Film D 0 Wed Dec 31 23:59:59 1969
Programmi D 0 Wed Dec 31 23:59:59 1969

12151 blocks of size 16777216. 5561 blocks available
which is correct. When I type "dir Musica" I receive:

smb: \> dir Musica
DŽ䀀崮DŽ 2663897088 Wed Dec 31 23:59:59 1969

12151 blocks of size 16777216. 5561 blocks available
which shows that after the first level of directories I have problems.

sudo mount: no error with them. Nevertheless I cannot see anything after the highest level.

One interesting point: if I go in Netwrok with Nautilus I can see everything perfectly...

Cheers, and Merry Christmas to you as well!

December 24th, 2009, 05:59 PM
This seems an odd problem, but your last comment about Nautilus is a good signal :).

I would recommend you to modify temporarily your /etc/fstab file in this way:

/ /media/disco_backup cifs username=yourusername,password=yourpassword 0 0
/ /media/varie cifs username=yourusername,password=yourpassword 0 0
Are the remote directories mounted with this change?.