View Full Version : [all variants] compaq presario sr1139nx bios upgrade problem

December 12th, 2009, 01:50 AM
So I recently bought a SATA hard drive for my computer and I've got all the wires hooked up. I run a Compaq Presario SR1130NX and based on this old thread (http://ubuntuforums.org/showthread.php?t=510821) it would appear that in order to get this hard drive working I need to upgrade my BIOS. Fair enough, I tried following the steps to do that using freeDOS, but Compaq's bios software will only run in Windows XP (if you try it in freedos it just gives you an error saying that the program can't be run in dos).

So I downloaded a Windows XP Live CD and added the BIOS upgrade software to the .iso and booted up in Windows XP. I opened up the program and it started out running smoothly, but once I got past the terms of use agreement I got an error message saying "WBDDA3I.DLL not found" I have no idea what this library is (google didn't know either) and now I'm stumped on how I can get my bios updated so I can actually use this 1.5 TB hard drive I just bought.

Any thoughts would be appreciated.

December 12th, 2009, 01:55 AM
There's a typo in my title it's a sr1130nx (not a 1139)