View Full Version : [ubuntu] USB Headphones in 9.10?

December 8th, 2009, 08:36 PM

first off, I'm hoping this is the right forum to ask this question ... my problem is that my USB Headphones which worked just fine under Ubuntu 9.04 stopped working with 9.10. When I plug them in and open the sound properties, I can choose them for *input* but not for *output*. What can be done to fix this?


December 8th, 2009, 08:50 PM
Don't know about this. :---)

Interesting ... a long nose is normally a sign for somebody lying :D ... but thanks for replying anyway! That's far less frustrating than no reply at all...

... if it helps for anybody to answer, I'm suspecting some change in PulseAudio between 9.04 and 9.10 to be the culprit here. Apparently there were a lot of changes. Interestingly, my BlueTooth headset works much better now - but its batteries just ran dry :-/

December 8th, 2009, 10:45 PM
The friendly guys in #ubuntu-de hinted me towards looking for the headset's USB id, which is "0d8c:0006" (names itself "C-Media Electronics, Inc. Storm HP-USB500 5.1 Headset", sold as "Speed-Link Medusa 5.1 USB"). If there is additional diagnostics that could help troubleshoot this problem I'll gladly provide it! :-?

December 9th, 2009, 01:42 AM
Just in case anybody else stumbles over this at some point: a simple reboot solved the problem. Thanks.

February 24th, 2010, 04:11 PM

i have the same problem
i have speedlink medusa 5.1 usb headset
my input is already work but i still have problem with output

do you know any solutions?
because the reboot did not work for me


i almost solve my problem
i installed the package called: pulseaudio-dbg
but its not 100% yet
now my problem is that the system thinks that this is a 7.1 sound headset but its 5.1

November 20th, 2010, 04:39 AM
I just got a pair of the same headphones, which worked just fine until I unplugged/replugged them, when the Output disappeared... am totally hopeless when it comes to anything technical, could you please walk me through how to install pulseaudio-dbg?

November 20th, 2010, 12:27 PM
Sadly, 10.10 hasn't solved the problem for me, but I've since discovered that when you disable PulseAudio autorespawning and then start it manually in a terminal like "pulseaudio -vvvv", the headphone's output sink is present and works. The quadruple "verbose" argument seems to be necessary, too, so it is a little spooky. Still a good workaround though until the problem gets fixed.