PDA

View Full Version : [gnome] (firefox:1787): GLib-WARNING **: g_set_prgname() called multiple times



m42h31
December 8th, 2009, 07:32 AM
my firefox can't open with clicking it's icon on ubuntu 9.10. but i run it on terminal by typing firefox %u i found this error :
(firefox:1787): GLib-WARNING **: g_set_prgname() called multiple times

it just run well if i run with sudo
any solution to solve this problem?

m42h31
December 25th, 2009, 08:50 AM
is there no solution ??

5ulo
December 26th, 2009, 03:26 AM
the same here

Weevil
December 29th, 2009, 09:20 PM
I have to click the firefox icon in my panel twice, first time gets shut down again for some reason. Same error as you guys in terminal.



Hmz... this post says it gets fixed by removing the .mozilla folder from your homefolder. I'll give it a try.

http://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&comments_parentId=536197&forumId=1

rdewit
December 30th, 2009, 05:03 AM
Hmz... this post says it gets fixed by removing the .mozilla folder from your homefolder. I'll give it a try.


Hi, you do realise that you will lose all your Firefox settings (including bookmarks and addons) when you remove your .mozilla folder?
It might be safer to rename it to .mozilla.bak for example.

falconindy
December 30th, 2009, 05:41 AM
If it's that big of a deal to you, run it as:

firefox 2>/dev/null
They're just warnings though. No harm done.

bennig
January 6th, 2010, 06:02 PM
If I launch firefox it doesn't open. Also the firefox icon is missing.

First I tried reinstalling firefox through synaptic, that didn't work.

I tried launching it through terminal, I got this error:

GLib-WARNING **: g_set_prgname() called multiple times

I tried reinstalling libglib2.0-0, no change, then forcing libglib2.0-0 to run as version 2.22.2 instead of the latest version 2.22.3 - the error message went away, but firefox still didn't start.

After googling that I found this thread. Tried all 3 "solutions" in the thread.

I ran it as sudo, it didn't start, but gave no error.
I renamed my .mozilla folder, got the same error.
I ran it with "firefox 2>/dev/null" got the same error.

I still cannot get firefox to start. Has anyone been able to fix this issue?

bennig
January 7th, 2010, 05:28 PM
Anyone?

mugs
January 10th, 2010, 04:21 AM
This worked for me: I removed xulrunner-headless-1.9.2 and now Firefox starts

Bashar "
January 14th, 2010, 11:05 AM
i'm facing the same issue now with thunderbird but my problem is worse

i start it then it shows:
(thunderbird-bin:2702): GLib-WARNING **: g_set_prgname() called multiple times

few minutes of work it Segfaults (Segmentation Fault)

of course deleting .mozilla and .mozilla-thunderbird will delete the entire profiles and this is not an acceptable solution at all


and i don't have xulrunner-headless

mugs
January 14th, 2010, 11:40 AM
Do you have any of the moblin programs installed?

Bashar "
January 14th, 2010, 03:35 PM
no its fresh 9.10 installation then i copied my profile from my previous 8.10 installation

both TB 2.x

Bashar "
January 15th, 2010, 12:38 AM
Do you have any of the moblin programs installed?

just to confirm how do i dentify if i have any of moblin softwares installed?

kovi
January 15th, 2010, 04:18 PM
Uninstalling Miro player (http://www.getmiro.com/) solved the problem for me.

amadib
January 19th, 2010, 05:25 AM
I'm having this issue as well.

Sqeaky_TheTrulyOpen
January 19th, 2010, 06:24 PM
I too am having this issue and removing the .mozilla folder did not correct it, and I do not have xulrunner-headless installed.

ie@fromru.com
January 21st, 2010, 01:03 AM
It happened after Firebug 1.5 update. I started FF by running "firefox -safe-mode" in command line and disabled Firebug 1.5 add-on, only after that I managed to run FF as usual.

pkts2
February 3rd, 2010, 06:13 AM
Fixed!. Instead of deleting the whole .mozilla folder found out that the offending file is actually "compatibility.ini".

Not sure what this file does but renaming it does the trick.

m_a_r_k_y
February 10th, 2010, 11:38 PM
http://ubuntuforums.org/showthread.php?t=1362942

calamar_
February 14th, 2010, 12:10 PM
Finally I found out a better solution to this problem I was having as well.

Just go to the profile folder under your ~/.mozilla/firefox/... There you'll see 3 files named like extensions.something

I tried first removing the three of them and it worked.

I wondered first if the problem could be with any of the extensions I got installed or updated. That's why I got there.

Anyway, I deleted then just the file "extensions.ini" and it worked too. So, try your own and let us know.

Thanks all.
Alex

SirGe
February 17th, 2010, 03:03 AM
I had the same problem. The messages ((firefox-bin:22382): GLib-WARNING **: g_set_prgname() called multiple times) appear to be an unrelated symptom. Prism seems to be the issue.

Part of the apparent reason for many different proposed solutions is that once I successfully start firefox in safe mode (i.e. with -safe-mode), it restarts fine without any additional options. Once. If I stop it and try to start it again, it fails without any additional messages.

None of the above proposed cures fixed the problem in my case.

By a tedious process of alimination, I identified the trigger as prism: if I disable it, I have no problems, if I re-enable it, I bring the problem back. This extension is not particularly useful: it enables you to create prism launchers from Firefox, but you can do the same by editing XML files...

My versions: FF 3.6.2pre, prism 1.0b3 (from http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu): I _really_ wanted tear-off tabs :)

This helped me realize just how much I depend in firefox working properly on my desktop - loads of thanks to all the Mozilla developers!

HTH

harpoonz
February 20th, 2010, 12:51 AM
Thanks for doing the legwork SirGe! I was getting the same message until I disabled Prism.

sambatyon.abulafia
February 20th, 2010, 10:04 AM
OK guys, I took the time to disable all the add ons and enable them one by one until the bug show itself. At the end, the add on which was causing all the problems was greasemonkey.

ben2talk
February 20th, 2010, 10:14 AM
I have to click the firefox icon in my panel twice, first time gets shut down again for some reason. Same error as you guys in terminal.



Hmz... this post says it gets fixed by removing the .mozilla folder from your homefolder. I'll give it a try.

http://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&comments_parentId=536197&forumId=1

I think this is a problem in the file 'compatability.ini'. I have multiple profiles, so I opened /home/ben/.mozilla and clicked the magnifying glass, entered 'compatibility.ini' and deleted them all.

Firefox started perfectly - but only one time.

So, I edited 'compatability.ini' to read as follows:

[Compatibility]
LastVersion=3.6_20100124075447/20100124075447
LastOSABI=Linux_x86-gcc3
LastPlatformDir=/usr/lib/firefox
LastAppDir=/usr/lib/firefox

Then I saved it, and made it READ ONLY - then copied and pasted it into each of the profile folders.

Now I can launch Firefox normally, and this file isn't rewritten in a way that stops it launching ;)

shellehs
February 25th, 2010, 12:50 PM
@ben2talk thanks, it works 4 me~~

pho3nixf1re
February 25th, 2010, 11:48 PM
i was having the same issue. in the compatibility.ini file i changed



[Compatibility]
LastVersion=3.6_20100218182626/20100218182626
LastOSABI=Linux_x86_64-gcc3
LastPlatformDir=/usr/lib/firefox-3.6
LastAppDir=/usr/lib/firefox-3.6


to



[Compatibility]
LastVersion=3.6_20100218182626/20100218182626
LastOSABI=Linux_x86_64-gcc3
LastPlatformDir=/usr/lib/firefox
LastAppDir=/usr/lib/firefox


notice the difference in the platform and app dir settings.

be sure to change the file to read only, otherwise firefox will overwrite the fix.

pho3nixf1re
February 25th, 2010, 11:58 PM
WARNING! changing the directories like i did removed all my extensions. will post back if i can figure out what happened. at least firefox works. good thing firefox isn't my main browser anymore ;)

Arkitekt
February 27th, 2010, 03:41 AM
OK guys, I took the time to disable all the add ons and enable them one by one until the bug show itself. At the end, the add on which was causing all the problems was greasemonkey.

I also discovered this, but the reason it is causing a problem with 3.6 is because greasemonkey seems to not auto-update when a new version comes out, most of us have pre-3.6 versions. I myself had a version from January of 2009. Looks like in 0.8.3 greasemonkey added a 3.6 compatibility flag. Updating manually from the add-ons website to 0.8.20100211.5 fixed this issue for me.

I fixed my GLib warnings by downgrading libglib2.0-0 and libglib2.0-data to 2.22.1-0ubuntu1, the newest one from karmic-updates (2.22.3-0ubuntu1) seems to be unstable. For those wondering how to do this, in synaptic highlight the package and under the package menu on the toolbar select force version (CTRL-E).

Hope this solves this for everyone.

Deathspawn
March 2nd, 2010, 12:01 PM
I had the same problem. The messages ((firefox-bin:22382): GLib-WARNING **: g_set_prgname() called multiple times) appear to be an unrelated symptom. Prism seems to be the issue.

Part of the apparent reason for many different proposed solutions is that once I successfully start firefox in safe mode (i.e. with -safe-mode), it restarts fine without any additional options. Once. If I stop it and try to start it again, it fails without any additional messages.

None of the above proposed cures fixed the problem in my case.

By a tedious process of alimination, I identified the trigger as prism: if I disable it, I have no problems, if I re-enable it, I bring the problem back. This extension is not particularly useful: it enables you to create prism launchers from Firefox, but you can do the same by editing XML files...

My versions: FF 3.6.2pre, prism 1.0b3 (from http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu): I _really_ wanted tear-off tabs :)

This helped me realize just how much I depend in firefox working properly on my desktop - loads of thanks to all the Mozilla developers!

HTH

Yep. Seems correct. Just installed prism and shortly after, it failed to start. Did the firefox -safe-mode and shut off all add-ons and it popped up fine. Though, I do notice when starting it in Terminal, it still throws up these errors:


spawn@quernerium:~$ firefox

(firefox-bin:27247): Gtk-WARNING **: Unable to locate theme engine in module_path: "ubuntulooks",

(firefox-bin:27247): GLib-WARNING **: g_set_prgname() called multiple times

But it starts.

LouPirlu
April 1st, 2010, 01:25 PM
same problem, firefox 3.6 doesn't start (I see "Starting Firefox Web Browser" on the taskbar for a while, then disappears and nothing happens). Launching from the terminal I get the GLib warning.

launching in safe mode and disabling GreaseMonkey solved the Firefox-doesn't-open problem (but I still got the GLib warning), and downgrading the package libglib to 2.22.2 solved the warning (but again ffx didn't start). They seem to be two different issues.

watchpocket
April 9th, 2010, 08:25 AM
. . . and downgrading the package libglib to 2.22.2 solved the warning (but again ffx didn't start). They seem to be two different issues.

I did this.

It helped a Firefox problem I was having, but for several weeks now my Update Manager still shows (as recommended updates) version 2.22.3 for both libglib2.0-0 and libglib2.0-data.

Do I need them for anything, since I'm currently running 2.22.2?

How does one get them out of the Update Manager? Synaptic has nothing newer for them than 2.22.3.

I have to uncheck them every time I install updates. One of these days I'll probably end up installing them accidentally, along with other updates.

Suggestions, please.

mugs
April 9th, 2010, 10:29 AM
Highlight those packages and then go to Package on the menu bar and check lock version. Then it will show up under a category of pinned and you wont accidentally update it in the future.

DOMiller
April 12th, 2010, 07:39 PM
Have this error when starting Thunderbird, followed by segmentation error, similar to Bashar, except segmentation error comes immediately, before T'bird opens.

Tried ALL of the ideas mentioned in this forum; nothing makes a difference.

No problem with FireFox.

Any new ideas?

DOMiller
April 13th, 2010, 08:24 PM
Have this error when starting Thunderbird, followed by segmentation error, similar to Bashar, except segmentation error comes immediately, before T'bird opens.

Tried ALL of the ideas mentioned in this forum; nothing makes a difference.

No problem with FireFox.

Any new ideas?

Found the basic cause and solution:

I had previously installed, and had been using, the latest Version of T'bird (3). Subsequently, Update Manager reverted to an older version (2). *Apparently*, it didn't revert the dependents, though, and the combination of old T'bird and new dependents caused the problem. Again installing the latest version from http://getthunderbird.com resolved the issue (the Glib warning still appears, but no segmentation fault, and T'bird opens and runs normally). Installation instructions can be found here: http://tinyurl.com/instTB3
If TB3 had been installed previously, as in my case, the latter 1.5 steps on migration are not needed.

dogeatery
September 7th, 2010, 11:07 PM
This problem began occurring for me immediately after I installed Prism in Linux Mint 8. Prism now installs an extension in Firefox. I opened Firefox in safe mode and disabled the Prism extension and Firefox immediately began working like normal.

Anyone know how this will affect Prism?