View Full Version : [ubuntu] HP NC8430 - Audio/Sound does not work

December 8th, 2009, 05:51 AM
Since I upgraded to ubuntu 9.10 my sound does not work. in 8.10 & 9.04 it used to work on the headphone jack.

I downloaded the latest alsa-drivers from alsa-project and compiled and installed it successfully. No mater what I do - I cant get it to work.

Also made sure that I have the latest version of BIOS from HP updated.

Below link is my system profile with all details related to alsa.


Please help!!!

Thanks in advance.

December 9th, 2009, 02:15 PM
I am also having trouble with the sound on exactly the same hardware.

I found http://ubuntuforums.org/showthread.php?t=1043568 and I did the force-reload and the sound started working.

There were however numerous errors and this lead me to https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/267963.

I'm unsure if I've actually solved the problem but it seems to be working for now. :)

December 9th, 2009, 03:14 PM
Thanks ambo for your reply.

I did come across that post and tried force-loading the modules and all that good stuff. The volume is only working on the headset and when I use the docking station. However, the laptop speaker was not working.

I took the bull by the horn and disassambled the laptop to find out that the speakers in my laptop was bad. Nothing to do with the drivers I was loading.

Time for a new laptop I guess :).

For those of you having this issue - I am documenting future reference - these options have worked for me when I changed in


Added the below options

options snd-hda-intel model=hp-bpc
options snd-hda-intel enable=1 index=0
options snd-hda-intel enable_msi=1

(Note: I guess you can send the above options in a single line something like
"options snd-hda-intel enable=1 index=1 enable_msi=1 model=hp-bpc" with out the quotes.
Since I was troubleshooting - I tried to load one option at a tiem and started testing.)