View Full Version : [kubuntu] 9.10 plasma freezing

December 8th, 2009, 12:59 AM
Hello all!
So all this has been happening for a while using ppa builds of KDE4 with 9.04, but now I'm running a fresh 9.10 install. This is on my laptop with an nvidia 9300M and the latest nvidia 195 drivers. Occasionally, and what is seeming like more often lately, plasma freezes. All my running apps continue to run, and I can Alt-Tab between them, but the background is frozen and the task/toolbar freezes. Occasionally it starts to work again, but this is very very rare. I have to restart the laptop as just stopping kdm (sudo stop kdm) and restarting it does not fix things, after I log in to kdm the desktop never shows up.

Let me know if there is any more description or information I can provide, but this has been driving me nuts for a while.


December 21st, 2009, 04:58 PM
anyone? is no one else having this problem?

a minor update, I disabled compositing and it still occurs, so whatever is happening doesn't seem to be an issue with that.

January 19th, 2010, 09:51 PM
I'm having the same problem and haven't found a solution yet. Like you said, rebooting is the only thing that seems to fix. I've tried killing plasma-desktop and then restarting it, it never comes back. Even with a full logout and log back in. A full reboot is the only thing that works :(

January 20th, 2010, 08:16 PM

Here is a quick fix:

Kill the desktop:

killall plasma-desktop

Move current config to backup:

mv ~/.kde ~/.kde~

Then restart the desktop:


sudo /etc/init.d/kdm restart
Though I didn't try the latter (kdm restart)

Pros: The desktop will work now
Cons: Have to redo your settings

There must be a better way. However this was quick...though dirty.

January 21st, 2010, 01:13 AM
To reset plasma settings you only have to rename/remove plasma's configuration files, not all of KDE's. They're the files beginning with plasma in ~/.kde/share/config/.

$ kquitapp plasma-desktop
$ mkdir ~/plasma-backup
$ mv ~/.kde/share/config/plasma* ~/plasma-backup
$ plasma-desktop

January 29th, 2010, 07:24 PM

Thanks for sharing the specific config files - I knew there must've been a better way!

February 2nd, 2010, 01:07 AM
I'm also experiencing this -though it's in intervals.
Usually it happens after network problems (maybe the network plasma widget?) or after I run netbeans -this puzzles me.

Have anyone filed a bug report? -if so can you please share the link (I can't find my way around the launchpad/bug system).

Edit: I had to figure out the plasma* config file - "fix" as well - so just editing to confirm that it works.

February 2nd, 2010, 06:48 PM
I have been having freezing problems on my desktop as well. Simultaneously I discovered a sound driver issue.

In my case:
Login - sound driver would fail (snd_hda_intel) and system would revert to pulseaudio.

After some time (30 minutes???), desktop would "freeze" or at least pause for several minutes. During this time input would be received and after a while everything would all of a sudden happen - desktop would roll or windows close/open...whatever I had tried to do during freeze.

When I looked into my audio issue, which I solved by reverting to a switch put in alsa-base that was required before 2.6.31-14 and moving pulseaudio down in the sound card list.

This seems to have stopped the freezing which I believe was caused by knotify4 trying to put a sound out.

February 3rd, 2010, 05:30 PM
Well my desktop is freezing again sort of - after doing the above post - next day (computer left running) I'm now getting a constant "pause" rather than a freeze. It lasts about 1.5 seconds but happens almost continuously - about 5-8 secs between pauses.

A look at the output from "top" shows plasma-desktop taking 96% or more CPU time during these short but frequent pauses.

A little reading on openSUSE and Fedora forums reveals a nVidia driver/xorg issue that may be the issue.

I am going to start by setting up a new user and see if a clean desktop fixes it. If not, I might revert to the older 173 nVidia driver.

Anyone else have any ideas???

February 4th, 2010, 08:22 PM
I tried a recommended nvidia-settings command to fix this but seemed only to make the time between "pauses" longer. Eventually, it went back to the 99% cpu like before.

However, logging out and re-logging in did fix the issue for a time (restarted the clock?). It's behaving sort of like a memory leak. Now I've added a few recommended things to my xorg.conf file. Let's see if these help anny...

If anyone wants to see the edits I've tried - let me know and I'll post them.

February 27th, 2010, 04:34 PM
Had the same problem on my desktop.

After reading here and there, I'd found this solution, hope it works for you as fine as it does for me.

Kmenu --> System settings --> Desktop.

1st under general tab check you have enabled desktop effects.
2nd under advanced tab check if you have disabled functionality checks.
3rd under general tab check if you have enabled or reenabled compositing.

Hope it works for You!:D

April 21st, 2010, 09:42 PM
This appears to be fixed in KDE 4.4.1 according to the entry for this bug in KDE's bug DB, but until we get that release, here's a temporary workaround:

When plasma starts getting unresponsive, open up a shell and type:

kquitapp plasma-desktop

followed by


This will restart plasma without requiring a logout or closing any windows. (Although sometimes Pidgin chat windows disappear from the taskbar...)

I have seen that "kquitapp plasma-desktop && plasma-desktop" should also work, but for some reason in my case, I need a few seconds between killing plasma-desktop and restarting it.

April 23rd, 2010, 01:21 AM
I've been having this problem, too. I'm going to try ceaualbi's suggestion but I thought I'd add that it seems to only really happen to me when I'm plugged into the wall (possibly also partially due to the fact that I remove my battery?) and not seeming to happen, or at least not as much, when I am running on batter power.

Thoughts? I'd rather not leave my battery in as it tends to decrease battery life in the long run, but the freezing is a real pain.

ETA: I tried kquitapp plasma-desktop and this was the output:

:~$ kquitapp plasma-desktop
<unknown program name>(4287)/: "Application plasma-desktop could not be found using service org.kde.plasma-desktop and path /MainApplication."


April 23rd, 2010, 01:49 PM
I've got two computers running karmic - one desktop which I've installed karmic from scratch on. this got no problems at all and one laptop upgraded from jaunty which have the problems discussed.

I've tried a lot of different scenarios and have found that it usually works if I run without "Folder View" and thus uses "Desktop" In the desktop settings dialog.

April 29th, 2010, 05:27 PM
I think I've fixed my issue. I noticed when I ran plasma-desktop in terminal, it kept coming up with an error which could only be related to the weather plasmoid I had up (something to do with a wind-speed type error or something). I removed that plasmoid, and - poof! -it's like magic, the desktop works as usual again.