PDA

View Full Version : [xubuntu] Where did my little speaker icon for alsa-mixer GO?



Chris Edgell
December 7th, 2009, 10:30 PM
I was planning on writing about a certain mixup that occurred with me and maybe others between the alsamixer as shown on the terminal, and the alsa-mixer showing when I click on the little grayed-out icon in the upper right-hand corner of my screen.

Now here, I want to show how my sound problem was finally solved:

Re: Getting sound on my "new" computer/
"After having just installed Xubuntu on a virtual box, I believe I
know what the problem is...In the upper right hand corner you should see a small faded speaker. Left click on it. It should open a window that Displays the title "Alsa-Mixer". In the lower left hand corner of the window should be a button that says "Select Controls" Click on that, you'll get a list of controls with a checkbox next to each.

Select "Master" and "PCM" from the list and hit "Close". Slide both of these up to max (or near max) and then note that perhaps it still has the little Mute icon turned on for Master volume? It will show like a little red X, click on that and you should have sound!

AND I DO, I do have sound. I just wanted to tell you how I got it... thanks to a sharp Ubuntu user.

Now if you have been able to follow my story, can you tell me not only HOW I GOT the little grayed-out speaker icon for the alsa-mixer (which I have NEVER heard mentioned in all these threads about sound), BUT ALSO where it WENT?

[That window for the mixer was so much more "user friendly" than the one they show on the terminal]

Sir Jasper
December 7th, 2009, 11:17 PM
Hi,

If you type alsamixer in a terminal is that what the result used to look like?
If yes, the next step is create a launcher icon.

Meantime if you click the Blue Mouse then Multimedia is the bottom item Volume Control?

My regards

Chris,

I didn´t read all your post, and I still haven´t. What is it you want? Is it the picture of the loud speaker?

Chris Edgell
December 7th, 2009, 11:29 PM
Hi Sir, thank you for responding.

Yes, what comes up on the terminal looks like always...
yes, how can I create a launcher icon?

Just what IS the blue mouse; where is it?

Sir Jasper
December 7th, 2009, 11:42 PM
Hi,

Perhaps you do not have a cute blue mouse icon on your panel. If you want one right click on a blank area in the panel where you want to place it. Then click Add New Items then scroll down the menu list to the very last item then click, then click Add.

Do similarly, but now go to the first item in the menu list and add the launcher. Then in the Command space type alsamixer (type any descriptions you want on the top two lines).

Test it works when you click it. If it does then click on the icon (above the Command line) go to the top of the screen and search through the icon lists for the loud speaker.

Cheers

Chris Edgell
December 8th, 2009, 12:07 AM
Now, I've found that the mouse simply does what my "Applications" does.

Then, I put the launcher up there, (there was no speaker to opt for, so I chose "Other"
I was offered the choice:
run in terminal
or
use start up notification

I pressed neither.

you say click it and see if it works...it works insofar as to give me an icon up there....but when I click it now I get no alsamixer of course, because it's hooked to nothing. Shall I click "Run in terminal"? that scares me. One would think that there would be an alsamixer on the screen and I would have a way to get a shortcut icon from there -- There WAS a window with the alsamixer in it that came when I clicked on the grayed-out speaker...that's my question: where did my speaker icon go, where did my alsamixer window go?

Chris Edgell
December 8th, 2009, 12:13 AM
Maybe I shouldn't be asking where the launcher went, I should be asking where the window went.

Sir Jasper
December 8th, 2009, 12:24 AM
Hi again,

I could only guess at how it disappeared. I am explaning how to get it back.

If you can put a Launcher on your panel type alsamixer in the Command box. By all means tick run in terminal. Then test if it works.

I will be back for a few minutes in about two hours so perhaps someone else may pick up the thread - but it is pretty intuitive. If you have dire trouble perhaps post a picture or two.

My regards

Chris Edgell
December 8th, 2009, 12:31 AM
Now I know what it means, "Run in terminal" hahah it means it will be in terminal...
I don't want it in terminal, I want that window where you see all that (those slides etc) but in the bottom left corner it says, "Select controls" when you press that another box opens up that offers you about 10 places where you can click to get a volume slide setup. and then at the top there's a tab that offers you some other choices if I remember correctly--has anyone seen THAT window v. the one in terminal??

Chris Edgell
December 8th, 2009, 12:36 AM
Well, I should forget the theoretical questioning (to some extent). I should count myself lucky that I got my sound back. Maybe some update eliminated that window and thought that all adjustments could be made in the terminal and we didn't need a window box for any of it.

Sir Jasper
December 8th, 2009, 12:37 AM
When you click the icon you will see the picture via the terminal command in the launcher. Just try what I say before you post back.

I really have to go for now.

Good luck.

Chris Edgell
December 8th, 2009, 01:26 AM
>>>as if I don't.

As I said, I didn't want the mixer only displayed in the terminal format, I wanted that window. But again, I CAN make do with the display in terminal, in which case I don't need that launcher.

But thank you, Sir Jasper.

Sir Jasper
December 8th, 2009, 02:58 AM
Hi,

The words ¨that window¨ are not helpful when I cannot see ¨that window¨ and there is no description of it other than it has sliders.

Do you recognise, want or need any of the three Volume related items in this picture:

http://i.imagehost.org/t/0624/alsamixer.jpg (http://i.imagehost.org/view/0624/alsamixer)

Your old computerś Xubuntu desktop did not seem to be much the same as mine and neither does your new one, but it is some 6 months since I configured mine and I can´t remember what my options were then.

My regards

PS I was and am too tired and busy for an essay; so all I wanted was a brief description of your needs and some detailed feedback so that I could try to help you.

Chris Edgell
December 8th, 2009, 03:21 AM
You don't have to waste your time with my questions or problems. I'm sorry, just don't bother with me, I'll find what I need. (Not that I haven't liked your efforts till now but it seems I've become a burden to you...please don't bother.)

But thank you anyway. You needn't respond, your tone has told me all.

Chris Edgell
December 8th, 2009, 03:34 AM
I'm sorry I took offense, You've been very kind. But let's leave this alone.

Sir Jasper
December 8th, 2009, 03:56 AM
Hi,

I apologise that I did not read your first post thoroughly; however you are mistaken in reading anything into my words other than I am busy and tired and since you have Xubuntu 9.04, as I do, and since you have PM´d me previously asking for help - I always try to help you (and sometimes other members).

My own set up suits my needs almost perfectly, but I would have been interested in your experience with Virtual Box which I may try out.

Perhaps I do need a rest from the forum, so Iĺl take one, at least until The New Year.

My regards

Chris Edgell
December 8th, 2009, 04:50 AM
There is no need to declare your vacation from the forums...just do what you like.

I have no experience with virtual box, that guy who helped me did use it.

Blessings
Chris

Sir Jasper
December 8th, 2009, 01:04 PM
Seek and ye shall find

http://i.imagehost.org/t/0292/ChrisE.jpg (http://i.imagehost.org/view/0292/ChrisE)

even the loud speaker icon

Chris Edgell
December 8th, 2009, 03:06 PM
I got up this morning, poured my coffee, and turned my computer on. I had a message for updates in the top right area, when I went to click it off, imagine my utter shock to see the grayed out speaker that I've been talking about. Of course when I clicked it there was the "window" -- the Alsa mixer -- and even tho' I had guessed there to have been about 10 options for sound "slides", actually there are 20. Here's a screenshot with the box that happens when I press the button in the bottom right corner. I even remembered when my old MS screen manager said, "If it goes away by itself, it could come back by itself". (And that HAS happened to me!)

Oh, yeah, and my shock doubled when I went to this thread and found you, Sir Jasper, with YOUR screenshot of ta--da--the Alsa mixer.

PLEASE bear with me for a couple of questions, even if they seem childish and/or obvious to you.

1. Me finding mine and you finding yours weren't related were they?
2. If we're both using Jaunty and/or up to date Alsa Mixers, why don't they look more alike?
3. How did YOU find it?
4. When you mention like, "Now you've got it, even the little speaker..." on your screenshot I don't see a little speaker, so how did you know I got a little speaker?

It all seems curiouser and curiouser.
Smiles and laughter...

Thank you Sir Jasper for hanging in there with me!

Ghost|BTFH
December 8th, 2009, 03:06 PM
I'm not really sure what to say on this, other than the speaker icon in the upper right is there by default in Xubuntu. When I tested it out in Virtualbox, literally the first time I logged in, I noticed it in the upper right hand corner.

I also noticed right away that I had no sound. Since the icon looked rather grayed out to me, I put 2 and 2 together and figured that the two had to have something to do with each other, checked the icon and sure enough found it to have all the sound turned down to zero.

Add to that, even turning them up to 100% didn't get sound (which would stump any new user - Bad developers! Bad BAD!) and I had to physically tell it to unmute (apparently telling it I wanted 100% volume wasn't good enough!) the master control.

As to where it went/came from, I have no clue other than to say it was there the whole time and probably ignored by 90% of those who tried to help you because - it's the very first thing you'd check.

A lot of times, we forget those obvious tech questions "Is it plugged in?" "Are you sure your monitor is plugged in and turned on?" "Are you sure you've hit the power switch and not the reset switch on the computer?" and those are the ones that can sometimes nail us in the butt when we're trying to help resolve an issue like this.

Personally, I'm just really glad I could help.

As for Virtualbox, if you'd like to toss me a personal message Sir Jasper, I'd be happy to tell you whatever I can about it - works like a charm for me. It's been a life saver for my clients who use Windows. When they call with a minor problem, I can fire up the Virtualbox to the appropriate version of Windows and walk them through step-by-step where to find the solution. Saves me a 5 minute call-out and saves them $30.

Cheers,
Ghost|BTFH

Chris Edgell
December 8th, 2009, 03:08 PM
Where's that screenshot?

Chris Edgell
December 8th, 2009, 03:11 PM
Oh, I am just SO happy right now!

Thanks for all, Ghost, I'm feeling that feeling, like Santa Claus came!

Chris Edgell
December 8th, 2009, 08:42 PM
I want to enter the screenshot but can't seem to get it on.

New reply
manage attachments
browse - upload
Submit reply ???

Ghost|BTFH
December 9th, 2009, 01:36 AM
This is a first attempt for me, but I'll try to do so...

http://ghost.thewatch.org/pix/1.png

I hope the image isn't too big, but still large enough to see.

Cheers,
Ghost|BTFH

PS: Please save and host this image somewhere and repost it if you feel it is worth the time, as their location is temporary and may disappear over time.

~Ghost

Chris Edgell
December 9th, 2009, 03:05 PM
What does your PS mean?

I'm afraid this thread is quite disjointed, containing odd fragments. So I think most people with sound problems would not read through it to the end.

But just in case, I have to make an embarrasing confession (although no one pointed this out to me--that has to be due to lack of clarity or someone would have told me..)

Click on Applications > Multimedia > MIXER!!!
and there pops up the mixer I've been begging for the location of, the one in a window=type box NOT the one on the terminal.

So now this is really solved (except for why I can't seem to post a screenshot).

Ghost|BTFH
December 9th, 2009, 03:13 PM
Posting a screen shot is a Texas two-step.

Step 1: Have a website host the picture so you have an URL (like whatever.com/mypic1.jpg)

Step 2: Click on the insert image icon in the reply box (It's the 5th icon from the right and looks like a little yellow square with a mountain and a sun in the background) and paste the http link to your picture there.

This will generate the image tag to allow your screen shot to be posted.

Cheers,
Ghost

Chris Edgell
December 9th, 2009, 03:31 PM
This is hard for me to understand....but I'll try harder if I don't get an easier way.

There MUST be an easier way because I posted a screenshot another time and it was easy and I don't know why I can't again.

Ghost|BTFH
December 9th, 2009, 03:35 PM
You could do an attachment and upload something from your computer. However I don't believe it will post the image, I'm not sure...I'll give it a shot with a test image I have here...

See if this works.

Cheers,
Ghost

Chris Edgell
December 9th, 2009, 03:42 PM
Will you look at thread #1288496?

Oh, The instructions there are true for me--and now2 I'm attaching a screen shot and IT will show you why it wasn't getting posted. At the tip you see "Invalid somethingorother
Does not upload
and in the box "manage attachments" now I see that if it DID upload correctly, It indicates that clearly.

Slowly but slowly...

Chris Edgell
December 9th, 2009, 03:44 PM
I see your image, I never even thought about posting an image, I was only aware of posting screenshots. Well, I've got that down now.

Nice to see you.

Ghost|BTFH
December 9th, 2009, 04:19 PM
Life is good, once you know the rules. :)

Cheers,
Ghost