PDA

View Full Version : [SOLVED] what are these packages n do i need them??



JamesParnell
December 7th, 2009, 09:23 PM
the following packages have been kept back:
bind9-host dnsutils libbind9-50 libdns50 libisc50 libisccc50 libisccfg50
liblwres50
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

nothingspecial
December 7th, 2009, 09:35 PM
Depends on weather you`ve got anything installed that depends on them.

JamesParnell
December 7th, 2009, 09:36 PM
can i find out what uses them, if anything.

nothingspecial
December 7th, 2009, 09:55 PM
Very easy answer.

Are you seeing this message after using apt-get?

Have you ever used dpkg or compiled from source?

If the answer to the first question is yes and the second is no....


..... then you can remove them.

JamesParnell
December 7th, 2009, 09:58 PM
Have you ever used dpkg or compiled from source?

HA, like i know how to do that. i guess i can remove them then, thanks for the help

SuperSonic4
December 7th, 2009, 10:03 PM
HA, like i know how to do that. i guess i can remove them then, thanks for the help

If you used aptitude, synaptic or software centre then you used dpkg

if not you installed from source

Of course it's rarely that simple but it's a good rule of thumb

nothingspecial
December 7th, 2009, 10:09 PM
HA, like i know how to do that. i guess i can remove them then, thanks for the help

Yes you can. That`s part of the point of a package manager. If it`s telling you that you don`t need the packages then you don`t.

Of course, if you have a lot of free space, and leave them there, then you won`t need to download them next time you install an app that depends on them. My way of doing things is to leave them there.

But then this is linux, do what you will;)