PDA

View Full Version : [SOLVED] how do I fix it???



freedomsearcher2442
December 7th, 2009, 10:42 AM
I installed adobe flash player but now I am gettiong an error that says the download messed up and I cant open update manager so I have no idea how to fix this without reinstalling everything I tried to fix it thru terminal but I dont fully understand how to use the commands and such

wojox
December 7th, 2009, 10:44 AM
Try this



#Remove Flash
# Deletes a troublesome config file
sudo rm /var/lib/dpkg/info/adobe-flashplugin.prerm
# Force-reconfigures adobe-flashplugin
sudo dpkg-reconfigure adobe-flashplugin --force
# Force-removes adobe-flashplugin
sudo dpkg --purge --force-all adobe-flashplugin
# Installs flashplayer the easy way
sudo apt-get install flashplugin-nonfree

freedomsearcher2442
December 7th, 2009, 10:48 AM
I hate sounding stupid but if you dont ask you dont learn where would I put that code?

rasmus91
December 7th, 2009, 10:53 AM
In your terminal...

freedomsearcher2442
December 7th, 2009, 10:57 AM
I understand that I asked wrong, I dont understand the code though how do i type it the whole thing? piece by piece and if so what pieces when I'm really new to this and havent used a dos like environment since I was probably 8

SwatKat
December 7th, 2009, 11:32 AM
Go to Applications> Accessories> Terminal


sudo rm /var/lib/dpkg/info/adobe-flashplugin.prermCopy the above line(whole), paste it in your terminal and hit enter. Type your password when prompted.

Then copy this line, paste it in the terminal and press enter


sudo dpkg-reconfigure adobe-flashplugin --forceRepeat the process with the next 2 lines, one by one


sudo dpkg --purge --force-all adobe-flashplugin
sudo apt-get install flashplugin-nonfreeI borrowed the codes from wojox(Copy pasted it:)). I just told you how to enter it in your terminal, thats all.

hal10000
December 7th, 2009, 11:33 AM
I hate sounding stupid but if you dont ask you dont learn where would I put that code?

All lines in posting 2 without a leading # are commands.
Try one or more of them, but first perform:
[code]sudo apt-get update[code]

freedomsearcher2442
December 7th, 2009, 11:36 AM
when i type in the first line this is what I get rm: cannot remove `/var/lib/dpkg/info/adobe-flashplugin.prerm': No such file or directory

freedomsearcher2442
December 7th, 2009, 11:42 AM
ok guys thanks alot i got it to work just ignored the first command and went from there