PDA

View Full Version : [ubuntu] Cairo-Dock Uninstall Problem



Haris-MV
December 7th, 2009, 10:19 AM
I have removed Cairo-Dock using Commands but still this one appears and it does start when I click

http://img31.imageshack.us/img31/9217/screenshotug.png

ajgreeny
December 7th, 2009, 11:03 AM
Reboot? The program may still be running in memory if you have not rebooted, or at least logged out and in again.

Haris-MV
December 8th, 2009, 12:59 PM
I rebooted It's still there

I tried to remove it again. but its not working



haris@ubuntu:~$ sudo apt-get remove cairo-dock cairo-dock-plug-ins
[sudo] password for haris:
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Terl
December 8th, 2009, 01:08 PM
How did you install it? How did you uninstall it? You said "using commands"; what do you mean? I installed Cairo dock through synaptic and it is in accessories and yours is in system tools. If you did not use synaptic to remove maybe give that a shot...

Haris-MV
December 8th, 2009, 01:16 PM
I installed From the Repository

ukripper
December 8th, 2009, 01:18 PM
Try this :

sudo dpkg --remove --force-remove-reinstreq cairo-dock cairo-dock-plug-ins

Terl
December 8th, 2009, 03:29 PM
Got it. Using synaptic, look and see if you still have cairo-dock-core and cairo-dock-data installed. If so remove those two and the whole thing will be gone. I just tried it. I first uninstalled cairo-dock and was left like yours. Went back and found those other two.

Apparently, when you select it to be removed it misses those two pieces....