View Full Version : [ubuntu] Mysterious GTK package error on automatic update

December 6th, 2009, 06:05 PM
Hi everyone,

I am running 9.10 Karmic without any problems for the most part. I ran the update process a few days ago and it told me about some broken packages. This was the returned message:

E: /var/cache/apt/archives/libgtk2.0-common_2.18.3-1ubuntu2_all.deb: subprocess dpkg-deb --control returned error exit status 2
E: /var/cache/apt/archives/gtk2-engines-pixbuf_2.18.3-1ubuntu2_i386.deb: subprocess dpkg-deb --control returned error exit status 2

I removed a graphics card recently and changed video back to the built-in video on the motherboard. I am unsure if this is what caused the error? I can find these packages in Synaptic, but when I click "upgrade" the same error messages appear. I don't want to remove them because Synaptic says that Ubuntu-Desktop package will be removed if I do it (and that sounds bad).

Any ideas what could be causing the errors on installing those packages, or even better, how I might resolve the issue?

Thanks everyone!!