PDA

View Full Version : [ubuntu] Title bar disappears when visual effects enabled



Squash101
December 6th, 2009, 12:12 PM
When I turn on the "visual effects" (System/Preferences/Appearance) every window appears without a title bar, and the minimize/maximize controls are gone.

I just installed 9.10 (clean install over 9.04) and had a little trouble with the NVidia graphics driver. Got that sorted out (downloaded and installed the drivers from NVidia website) but this problem now shows up.

Any ideas?
Using: Dell D800 with NVidia GeForce 4200 GO card
graphics driver downloaded: NVIDIA-Linux-x86-96.43.14

doughed2003
January 10th, 2010, 02:01 AM
same here.not sure if it's a program conflict but I'm trying to get the cube going and not much joy.

auh2o
January 15th, 2010, 09:06 PM
If you didn't solve this yet:

Add this line to the "Screen" section in your /etc/X11/xorg.conf file:


Option "AddARGBGLXVisuals" "True"

doughed2003
March 30th, 2010, 11:03 PM
how do i do this? i'm not to good with command line aside from copy and paste.

mobasher_helmy
April 13th, 2010, 09:39 PM
open a terminal

% sudo vi /etc/X11/xorg.conf

scroll with your arrow keys to the Screen section
then press i
write down the statement from auh2o
Option "AddARGBGLXVisuals" "True"
then enter
then press escape ESC key
then type :wq! (colon... wq ....exlamation mark)

done...

doughed2003
April 14th, 2010, 04:37 AM
i don't see where screen section is ?
heres what the first command gives


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Sat Jan 24 20:04:42 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
# # generated from default
# Identifier "Mouse0"
# Driver "mouse"

krige
April 15th, 2010, 04:39 PM
Try running:

sudo apt-get install compiz

doughed2003
April 16th, 2010, 05:38 AM
i have compiz .i have metacity . i don't have a super great video card but it will do the cube and stuff because i can get it to work on the super ubuntu that i put on a flash drive that i can boot up my pc with.

MBilyeu
March 4th, 2011, 08:29 PM
I'm not sure if it would be the same for anyone else, but I noticed that if I disable the reflection effect for windows, the title bar returns. The effect is still present for the cube.