View Full Version : [ubuntu] 9.10 after update gdm extremely slow to start

December 5th, 2009, 06:24 AM
Please bare with me, as my experience with Linux/Ubuntu is minimal.

I have installed 9.10, and was quickly (through some online help) able to get my wireless & NVidia graphics driver (non-free from NVidia's site) running.

Everything was moving along fine until my most recent set of updates.

Firstly, while rebooting after a system update today, I was greeted with a warning saying that I could not run in my standard graphics mode. I tried to make sense of the error log, which had something to do with not being able to load the NVidia module, and was sent directly to the terminal login for tty1.

I logged in and reinstalled the NVidia driver, then used the command:

sudo service gdm start

and was greeted by the graphical login screen. Success, right?

Not exactly...now, when I reboot, I am occassionally sent directly to the graphical login screen and occassionally sent to the terminal login for tty1. If I wait long enought (some times up to 5 minutes), gdm will eventually start.

If I manually start the service, I can get into the graphical login.

My best guess is that some service/module is not consistently loading correctly while Gnome is trying to start, but I'm at a loss to figure out which one. Would any of you gurus mind pointing me in the right direction? I'm trying to learn, not just get it working, so I would really love either a reference, or an explanation instead of just code.

Thanks for putting up with my extensively worded quandry, and thanks in advance for any advice,

December 5th, 2009, 06:35 AM
Ubuntu provides pre-built versions of the proprietary Nvidia drivers, which is unusual for a linux distro and one of the reasons for it's popularity.

If you did get the nvidia driver from nvidia, run the uninstall script that came with it, reboot, and go to administration->hardware drivers. These are from nvidia too. You may think it amounts to the same thing, but in fact, the installer you downloaded from nvidia must compile a kernel module on your system, and nvidia simply do not understand the kernel and OS as well as ubuntu. Ie, you are most likely better off going that route.

December 5th, 2009, 07:58 AM
Thank you for the advice. It is duly noted and shall be followed, but it does raise a few questions, if you don't mind.

I have been under the assumption (perhaps incorrectly), that one is typically better off using a more recent driver than an older version, is that assumption incorrect?

I am also intrigued by this, as the driver has been working beautifully since I installed it on 9.10 about a month ago, and has only begun having problems after the recent update, could it be the update of the kernel or another package that is causing this? If so, how can I find out?

December 5th, 2009, 09:05 AM
So, to uninstall the NVidia driver, I went to their website and followed their instructions to run the script, using the command:

sudo nvidia-installer --uninstall

I then rebooted, and was agian greeted by a "limited graphics" dialog saying that ubuntu couldn't find the nvidia module.

I went ahead and opened in "limited graphics", and followed your instructions for installing ubuntu's hardware drivers, rebooted, and other than some weird flashes of color and a small bit of hang in the animation of the splash, everything worked fine.

Just for the heck of it, I went one step further and reinstalled NVidia's non-free driver. It still worked a treat. I'm going to chalk this up as something strange occurring during the update that required an uninstall/reinstall of the video driver.

February 7th, 2010, 10:14 PM
I have the same problem. However, I have an ATI video card in my Dell Inspiron laptop. I'm running the video driver that Ubuntu installed as the default. I agree, I think this began after a series of updates.

I've combed through a every log file I can find and I can't seem to find anything that is causing this. I am intersted in help with this as well.