View Full Version : [ubuntu] Dual Screen Problem

December 3rd, 2009, 06:03 PM
I use two screens when I run Windows7 and it works fine, obviously.
And it's really not much of a problem/inconvenience to use only 1 monitor when on Unbuntu.

Only real problem is this:

As you can see, the desktop is stretched, or it seems doubled.

I can move my mouse into the black space (It pans the whole screen over when the cursor pushes against the end of the monitor.) but cannot drag anything into it.
The windows can only be dragged to the end of the first 'part'.

Also, my second screen isn't the same size.
So it's not like it trying to recognize the second screen.

This monitor is 1280x1024.
The other is 1680x1050.

The graphics card I'm using is a 512MB nVidia Geforce 9500GS.
I installed the driver for it (the recommended one when searching for drivers after installing the OS) and then this happened.
I didn't have this problem before installing the nVidia drivers.

If you look at this, when I try to change the resolution to the right one, the screen goes black, and all I can see is the mouse.

http://img706.imageshack.us/img706/5240/screenshotw.th.png (http://img706.imageshack.us/i/screenshotw.png/)

I have the smaller monitor plugged into the VGA port of the card, and the larger one plugged into the HDMI port of the same card.

It picks up the smaller one as default.

I'm figuring this is a driver problem.

Any help is appreciated.


Also, those screenshots are taken without my 2nd monitor plugged in.
Here's one of the nVidia X Server Display Settings without the 2nd screen plugged in.
http://img11.imageshack.us/img11/9080/screenshot1ase.th.png (http://img11.imageshack.us/i/screenshot1ase.png/)

If I try and change the resolution settings in here the screen goes black as well.

Here is what it looks like after I plug in the 2nd screen, and then click "Detect Displays".
http://img31.imageshack.us/img31/8716/screenshot2pu.th.png (http://img31.imageshack.us/i/screenshot2pu.png/)

And the menu for the second screen, as well as the window that shows when I click configure.

If I select "Separate X Screen" I have to relog, but then the screen just goes black again.

Thats all I can think of to help.


Problem solved.