View Full Version : [ubuntu] Xserver fails to start after 8.10 to 9.4 upgrade

December 1st, 2009, 03:07 PM
I recently made the jump and wanted to upgrade from 8.10 to 9.10 (which requires going to 9.4 first apparently), but after the upgrade went well (at least I think, I didn't catch any major prompt/error) my Xserver won't start. I'm left with the command line login prompt.

It seems it's monitor/graphics cards related, but I tried many things found in the forum, but nothing helps.

Nothing changed hardware wise, but I'm still using this ancient Compaq AP500 box .... sorry!

I get the following error in gdm.log:

X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux oxbow 2.6.28-16-generic #55-Ubuntu SMP Tue Oct 20 19:48:24 UTC 2009 i686
Build Date: 09 April 2009 02:10:02AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@rothera.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/var/log/Xorg.failsafe.log", Time: Sat Nov 28 18:56:06 2009
(++) Using config file: "/etc/X11/xorg.conf.failsafe"
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.failsafe.log" for additional information.

ddxSigGiveUp: Closing log
3568 3187
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.

Then I get the following in Xorg.0.log:

(II) GLINT: driver for 3Dlabs chipsets: gamma, gamma2, ti_pm2, ti_pm, r4,
pm4, pm3, pm2v, pm2, pm, 300sx, 500tx, mx, delta
(WW) Falling back to old probe method for glint
(--) Chipset pm3 found

The command lspci gives me:

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:0b.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 04)
00:0c.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 05)
00:0f.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
00:0f.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
00:0f.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)
00:0f.3 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev 46)
00:10.0 Communication controller: Agere Systems Venus Modem (V90, 56KFlex)
00:14.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:14.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:14.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:14.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
01:00.0 Co-processor: 3DLabs GLINT Gamma G1 (rev 01)
01:00.1 VGA compatible controller: 3DLabs GLINT R3 (rev 01)

And here is my xorg.conf:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
# Load "freetype"
Load "glx"
Load "int10"
Load "vbe"

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "Device"
Identifier "3DLabs GLINT Gamma G1"
Driver "glint"
BusID "PCI:1:0:1"

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60

Section "Screen"
Identifier "Default Screen"
Device "3DLabs GLINT Gamma G1"
Monitor "Generic Monitor"
DefaultDepth 8
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"

Section "DRI"
Mode 0666

I did a lot or reconfigure xorg, --reinstall, etc ... but no help.

Does anybody have any thought?



December 1st, 2009, 08:21 PM
Hi Vince,

Well you have a lot of stuff in there you probably don't need. Most of it is configured elsewhere in Karmic. For example you shouldn't need the mouse and keyboard stuff. Do you have a Wacom tablet?

With the move away from xorg.conf to HAL/.fdi a generic Jaunty xorg.conf would look something like:

Section "Device"
Identifier "Configured Video Device"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
And in Karmic there might not even be one.

December 2nd, 2009, 09:58 AM
Thanks Favux for the feedback.

Do you have a Wacom tablet?

Yeah, I surely don't have that.

I have a basic (yet old) setup.

I'll try the basic xorg file you suggested, and see what it does.

Thanks again.


December 16th, 2009, 10:31 AM
Well, I tried to use the simplier xorg.conf file (actually the one called "failssafe"), but the result is the same: X server fails to start.

Then, I figured I should upgrade straight to Karmic, which went fine, but now I got a different problem (maybe related) where I'm stuck with a 600x480 resolution.
I seem to recall having this issue back in 5.4 ... but I don't recall what the fix was.
I'll search the forum for the solution.


December 16th, 2009, 11:32 AM
Well you might have to reinstall your drivers for the new kernel.

I can help you with nvidia cards but not so sure a bout ati.

open download.nvidia.com
username = guest
then cd to your needed drivers and use the get command to get them

December 16th, 2009, 11:39 AM
Hi sonic167,

I agree, you want to search the forum/google your card. Apparently it is a:

3DLabs GLINT Gamma G1

You might want to check with:

lspci | grep VGA

It might also be useful to go to the Xorg site and see what they say about the driver. I assume they're the ones responsible for it.

December 17th, 2009, 10:10 AM
I've actually be able to use the Synaptic Package Manager (while in 600x480) and searching for "glint" I saw that the package xserver-xorg-video-glint was not installed.
So, I installed it, but still only 600x480 is available for resolution (even after reboot).

Do I need to reconfigure xorg with
sudo dpkg-reconfigure -phigh xserver-xorg



December 17th, 2009, 10:26 AM
Hi sonic167,

Maybe, I'd hold off on that until you've researched a little more. Be sure to back up xorg.conf before you run it and you know how to restore the back up from the command line.

Then it was probably the VESA driver running it before.

Now you want to search/google for someone configuring the xorg.conf for it.

Is it the kind of card that uses the system RAM for video memory? Some of the Intel video chips need you to allocate more of the RAM for them. The default settings are too small so the video card doesn't have enough RAM for video memory to run higher resolutions. It's a thought anyway.