PDA

View Full Version : [gnome] No video thumbnail previews in nautilus



bburkert517
November 26th, 2009, 12:42 AM
Hi, I was messing around in the preferences of nautilus and clicked on compact view and then learned I didn't like that view so I switched it back to normal but ever since then I have been unable to view my video thumbnail previews. I have done some searching and have have tried reinstalling totem and totem-common, I have installed totem-gstreamer, I have all of the proper codecs installed and I have tried deleting ~/.thumbnails but I have had no luck. None of the settings under preferences -> preview seem to have any effect on it. I am throughly stumped :confused:

Any help would be appreciated thanks

Minsky
November 26th, 2009, 07:41 PM
In Nautilus, go to Edit>Preferences again and set Show_thumbnails to Always, and the limit to 4GB. Exit Nautilus and go to home directory/.thumbnails/fail/gnome_thumbnail-factory and delete everything in there to force Nautilus to rebiuld the thumbnails.
If that doesn't work then there's a couple more things that you can try. In gconf-editor go to apps>nautilus>preferences. in the right hand pane set the value of thumbnail_limit to -1. Also in gconf-editor, go to desktop>gnome>thumbnailers and scroll down until you see a list of settings in the format of video@####. Click on each one and make sure that it's enabled. Hopefully, one of those methods will solve your problem. if not, then I'm as stumped as you are.

esc1
December 13th, 2009, 09:34 PM
Tried all of this. Still doesn't work for me. :/

nutznboltz
December 13th, 2009, 11:56 PM
Is /usr/bin/totem-video-thumbnailer installed on your system?

Do you get this:


$ ls -l /usr/bin/totem-video-thumbnailer
ls: cannot access /usr/bin/totem-video-thumbnailer: No such file or directory

esc1
December 14th, 2009, 10:41 PM
Nope.


-rwxr-xr-x 1 root root 169472 2009-11-11 04:15 /usr/bin/totem-video-thumbnailer

esc1
December 15th, 2009, 07:16 PM
Bump.

esc1
December 30th, 2009, 08:43 PM
It was a simple fix. Just wanted to reply in case any noob like me has the issue. I like to use vlc but totem creates the video previews. My totem codecs were not up to speed.

tenjin1
March 10th, 2010, 02:16 PM
So what exactly was the fix?
there is no totem codecs package I can find per esc1 post.

I'm having the same issue. I don't want totem installed but want my video thumbnails to work. I've tried ffmpegthumbailer and also doesn't work. Everytime I go to install something that has to do with totem it wants to install the whole totem package again which I don't want totem but do want video thumbnails.

help?

kelvin.illa
March 13th, 2010, 07:12 PM
So what exactly was the fix?
there is no totem codecs package I can find per esc1 post.

I'm having the same issue. I don't want totem installed but want my video thumbnails to work. I've tried ffmpegthumbailer and also doesn't work. Everytime I go to install something that has to do with totem it wants to install the whole totem package again which I don't want totem but do want video thumbnails.

help?

I second this; I had to re-install totem to get video thumbnails back. Is there another way?

benerivo
March 13th, 2010, 09:33 PM
You can try nailer, which relies on having mplayer installed...

http://sites.google.com/site/kdekorte2/nailer

garrison
April 8th, 2010, 07:36 PM
You can try nailer, which relies on having mplayer installed...


It seems to also rely on having Fedora installed, but I did get it working:


sudo aptitude install gnome-devel
./configure; make && sudo make install
cp nailer.schemas /usr/share/gconf/schemas/
sudo aptitude install gnome-xcf-thumbnailer


Despite removing failed thumbnails and restarting nautilus, it didn't work until I installed gnome-xcf-thumbnailer, which presumably performs a step I missed.

Without ./configure options, these two files are installed in the wrong place:

/usr/local/etc/gconf/schemas/nailer.schemas
/usr/local/share/thumbnailers/video-thumbnailer.desktop

superconductor
May 6th, 2010, 04:47 AM
Assuming you have not uninstalled the default totem package and reinstalled totem-xine, the following procedure should work. It only requires you to install packages available in the standard Ubuntu repositories and does not require you to compile anything manually, as described above.

1. Open file manager.
2. Edit->Preferences->Preview. Change preferences as required.
3. Close file manager and open terminal.
4. Run the following command to install the necessary packages.

$ sudo apt-get install ffmpeg ffmpegthumbnailer gstreamer0.10-ffmpeg 5. Remove old thumbnails.

$ rm ~/.thumbnails/fail/gnome-thumbnail-factory/*
$ rm ~/.thumbnails/normal/*6. Open the file manager and enjoy your new thumbnails!

Please post back when / if this works. I think I've listed the minimum packages required for thumbnails using the default totem with gstreamer (NOT xine), but I might have missed a few.

dee4life2005
May 10th, 2010, 07:23 PM
Assuming you have not uninstalled the default totem package and reinstalled totem-xine, the following procedure should work. It only requires you to install packages available in the standard Ubuntu repositories and does not require you to compile anything manually, as described above.

1. Open file manager.
2. Edit->Preferences->Preview. Change preferences as required.
3. Close file manager and open terminal.
4. Run the following command to install the necessary packages.
5. Remove old thumbnails.
6. Open the file manager and enjoy your new thumbnails!

Please post back when / if this works. I think I've listed the minimum packages required for thumbnails using the default totem with gstreamer (NOT xine), but I might have missed a few.

I had un-installed totem and was using VLC instead, and my video thumbnails weren't working. After trying the above commands they have returned. Haven't checked all codecs yet, but it looks promising.

Thanks.

\\:D/

fritzm
May 20th, 2010, 08:09 PM
Thanks a lot - everything you list was installed except for ffmpegthumbnailer . Installing that and deleting the files fixed the problem. I had a new default installation of 10.4, so I think this is a bug in the default configuration.

Fritz

ephman
November 4th, 2010, 03:02 AM
superconductor thank you. worked like a charm!

thanks for the bandwidth,
ephman