View Full Version : [ubuntu] I can't upgrade the Flash Plugin

November 25th, 2009, 02:06 AM
I have Ubuntu 9.10, the latest Firefox. Trying to upgrade to Flash Player

Firefox tried to do the upgrade and this was the resulting message, which is the same message I get when I try to upgrade via sudo apt-get install flashplugin-installer.

E: The package adobe-flashplugin needs to be reinstalled, but I can't find an archive for it.
E: Internal error opening cache(1). Please report

I attached a screenshot of an error screen of an attempt to install Flash.

November 25th, 2009, 02:58 AM
I finally got it to work.

First I noticed the red upgrade icon in the upper right next to my wirsless signal indicator, I clicked to download and install the upgrades and restarted. An attempt to install the upgrade using the tool in the screenshot failed. Then I wen to Facebook and hit a page that prompted me to install the Flash upgrade and I did and then it worked.

Thanks any way, I hope this still helps someone else. I think the best thing I did was apply the system upgrade that actually removed the rogue upgrade attempt and install a ton of patches and upgrades.