View Full Version : [all variants] Access point on atheros AR2413

November 24th, 2009, 04:18 PM
Another non-standard problem.

I run multiple-uses Linux box: TV, movies, router, SMB and AP. The interesting part is Access Point.

I created it using madwifi drivers, and it's working fine. Except.

Recently I bought Asus R50A. It runs Windows7, and it's wireless card is Marvell SDIO one.

The problem is that when Asus connects to my AP, I get dreaded "missed beacon" bug - which is, from what I read, unsolvable.

So, the question is: are there any other drivers I can create AP on?

The hardware:
04:09.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)

November 30th, 2009, 04:52 PM
OK, found that ath5k+hostapd (+kernel >2.6.31) is supposed to work. Only problem, there's no usable howto.

So, please - does anyone know of one?

November 30th, 2009, 07:28 PM
This http://bobcopeland.com/blog/2009/11/ath5k-ap-mode/ worked flawlessly. All thanks to blog's author :-)