PDA

View Full Version : [ubuntu] Mono dependancy in 9.10?



RX8volution
November 23rd, 2009, 03:59 AM
Hello, I'm trying to install a package I very much liked (gnomeartng v0.7) which apparently fails because it's dependent on "mono-common" ... so package manager throws an error "ERROR: Dependency is not satisfiable: mono-common" ...

Does anyone know if there's a way to fix this, or a work-around?

directhex
November 23rd, 2009, 02:22 PM
The "correct" solution would be for the package to be fixed to properly track dependencies (you should *never* manually depend on mono-common)

However, you might want to look into the "equivs" package for hints on building a dummy mono-common which doesn't do anything but satisfy the dependency

margazhang
December 7th, 2009, 09:35 AM
How to build a dummy mono-common?