PDA

View Full Version : [SOLVED] Can`t connect to Hidden Wireless Network



_VZ_
November 21st, 2009, 09:25 PM
Hello to all!!!

After updating to 9.10 I can not connect to Hidden wireless network. I have created new Ad-Hoc network and entered static IP and WEP Key. When I trying to connect, I get attached image. I was surprised why the "Key" field is empty. Thats why, I think, "Connect" button is grey.

Can anyone help?

_VZ_
November 23rd, 2009, 02:20 PM
No ideas?

sotomajor
November 23rd, 2009, 08:54 PM
I've filed bug regarding this issue
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/461385

sgosnell
November 23rd, 2009, 09:27 PM
Don't create a new network, just left-click on the network icon in the panel and select Connect to Hidden Network. Enter the SSID, change the security information, and it should connect.

_VZ_
November 23rd, 2009, 09:58 PM
Thank you sotomajor. I think so also.


Don't create a new network, just left-click on the network icon in the panel and select Connect to Hidden Network. Enter the SSID, change the security information, and it should connect.

So worked when I 9.04 had and had no problem. In Ubuntu 9.10 this is does not work, when I have static IP and WEP-key and Ad-Hoc mode. Why? I do not know. :-(

sgosnell
November 23rd, 2009, 10:18 PM
Have you tried enabling the SSD broadcast temporarily, and trying a connection?

_VZ_
November 25th, 2009, 12:41 PM
Have you tried enabling the SSD broadcast temporarily, and trying a connection?

No. I do not know what is this. Can you tell me how can I do this?

sgosnell
November 26th, 2009, 01:25 AM
Go into your router's settings via your browser. It may help to read the manual for the router. The IP address should be either 192.168.1.1 or 192.168.0.1, those are the usual ones. Somewhere under the wireless settings there should be an option to enable or disable the SSID. Sometimes it's easier to get a system to connect to a router broadcasting the SSID (not 'hidden') and it will continue to connect after rehiding the SSID.

_VZ_
November 26th, 2009, 05:15 PM
I have not a router. I have created Ad-Hoc network in my notebook. In 9.04 first I connect to this created network (left click NM then "Connect to hidden wireless network" and then my network) and then other computers and mobiles connect to me.

joshuapurcell
December 3rd, 2009, 05:46 PM
I have this same issue. I am connecting to my work's hidden wireless network and I don't have the option for unhiding the ESSID. I start my laptop, once booted I choose 'Connect to Hidden Wireless Network...', select the correct network listed in the dropdown, and the data for that network connection populates but without the password as shown in the screenshot in the first post of this thread. It is uneditable, so I must then choose 'New' from the list and manually enter all that information again. Every time I boot up.

sgosnell
December 3rd, 2009, 06:01 PM
If you edit that connection, do you have the checkbox "Connect automatically", at the top of the dialog, checked?

Vasyl
December 8th, 2009, 08:59 AM
I solved this problem setting encryption key manually with sudo iwconfig bla0 enc blablabla
and then connecting with networkmanager

brookie
December 10th, 2009, 05:26 PM
Hello,

I am experiencing this in Karmic 32 bit on three machines with all the current updates. This bug seems like it has been duped with others here:

This looks like the original:
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/446394

Post #20 in #446394 has a workaround.

Duped in these:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/450097
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/449287
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/455161
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/461385

If this is indeed a dup of #446394 it should be marked as so and folks should post comments on the 446394 thread.

If people are still experiencing this like I was on a Broadcom BCM4318, probably no need to hack the driver with all the workarounds in other posts. The b43xx cutter driver actually works. The ndiswrapper hack I found in many posts was unnecessary in my case.

We should probably post info in the original thread at launchpad to get this fixed. Just sign up for an account and give the devs any information they may ask for.

Cheers,
brook

_VZ_
December 10th, 2009, 08:32 PM
If you edit that connection, do you have the checkbox "Connect automatically", at the top of the dialog, checked?

There is off. I tried check on and off but this does not help me.


I solved this problem setting encryption key manually with sudo iwconfig bla0 enc blablabla
and then connecting with networkmanager

This does not work. :(
I have entered:
sudo iwconfig wlan0 enc **********(my WEP)

To brookie (http://ubuntuforums.org/member.php?u=729189) and sgosnell (http://ubuntuforums.org/member.php?u=774876)
As I understand this checkbox work when this network is already on and I can connect.
But I want myself this Ad-Hoc network turn on.

Crick
February 17th, 2010, 06:32 AM
I think this issue may be related to the one stated here (http://ubuntuforums.org/showthread.php?t=288245):

I changed my SSID to an all-lowercase sequence (broadcast still disabled), and it is connecting fine now. Note that when it asks for the WPA2(personal) password, you put in the actual passphrase, not the psk generated by wpa_passphrase.

_VZ_
February 17th, 2010, 04:39 PM
My SSID was all-lowercase and it was not work.

But Bug-fix (https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/446394) helped me and now all work gut.

Thank you all for help!