View Full Version : [ubuntu] NetworkManager missing eth0

November 21st, 2009, 04:50 PM
After trying what i could: I am unable to figure out why NetworkManager does not handle eth0 (a wired interface).
Glancing through the logs (I am running Ubuntu Hardy):

Nov 21 20:59:47 ubuntu NetworkManager: <info> starting...
Nov 21 20:59:47 ubuntu NetworkManager: <info> Updating allowed wireless network lists.
Nov 21 20:59:47 ubuntu NetworkManager: <WARN> nm_dbus_get_networks_cb(): error received: org.freedesktop.NetworkManagerInfo.NoNetworks - There are no wireless networks stored..

It does not however seem to detect eth0.

My /etc/network/interfaces:

auto lo
iface lo inet loopback

iface eth0 inet static

auto eth0

From nm-system-settings.conf (This file was missing! I created it manually):



The NetworkManager applet simply states 'No network Connection', despite its settings showing eth0 correctly configured (The very reason I am able to post this thread :))

Any Help is greatly appreciated!!!

November 21st, 2009, 05:38 PM
Nwtwork manager does not manage interfaces if they are managed in /etc/network/interfaces. Try with everything removed or commented out of /etc/network/interfaces except for

auto lo
iface lo inet loopback

November 21st, 2009, 05:44 PM
If you need the static configuration, you should be able to add that through Network Manager's "Manual configuration". If you upgraded to Hardy from previous version (like I did), the upgrade process left the manual configuration in /etc/network/interfaces.

November 21st, 2009, 07:45 PM
Thanks Guys, but I had already tried these both b4 posting :)

I commented out everything from t interfaces file, and had NM configure it using t manual option.

Now, even though i can connect to t net, the NM icon on t panel shows an 'exclamation' mark, and on a mouse over, it shows 'No Network connection'.

Just to add (may its useful??), the NM folder in /etc was missing the file 'nm-system-settings.conf', and even now does not contain the folder 'system-connections', n likewise, a file for eth0.

This is t case with my Ubuntu box.

NM works fine for wired in OpenSuse on my other box, n even has the mentioned files.

I am really unable to find good documentation on NM!
Much as its easy to chuck it n turn to WICD, now my curiosity will not let me rest, until I know how to make it display my wired connection in active state ;)

Please Help :)

November 21st, 2009, 07:47 PM
n just to add again, the logs do not reflect NM accessing eth0.
This is what is bothering me........ :(

November 22nd, 2009, 01:53 AM
My Hardy /etc/NetworkManager directory contains only a directory named dispatcher.d I'll need to do some research to find (remember?) where NM stashes it's configuration.

November 22nd, 2009, 06:42 AM
Even i am checking on it.... will post if i do catch hold of something.

November 22nd, 2009, 08:08 PM

I had this same issue and from another thread I read about WICD

I installed it from Ubuntu Software Center and then followed these instructions -


to the T including getting network interfaces back to its original state of:

auto lo
iface lo inet loopback

I then configured wicd as a static ip and am very impressed with it over network manager. It is working flawlessly

November 25th, 2009, 07:32 AM
Well, finally i did away with NM!
IT even resolved my firefox automatically starting in offline mode. (I had tried modifying the config for firefox.... but i did not see it use NM).

I use WICD btw :).... on my laptop... It is really neat with wireless!

I am just curious to know what is it that WICD does that NM does not..... (Why on earth wont it work, for such a simple setting of mine!)


November 25th, 2009, 08:54 AM
Dear all,

but we already try with WICD and looks like good enough from NM, when the NM is ignored settings in /etc/network/interfaces beside lo

But right now i have a question, when i set the static address for eth0 with at WICD, after restart i always get , when see the proses use ps, i saw the dhclient is running.
so everytime after restart i should run the /etc/init.d/networking restart
this problem is make inconvenience to me because networking is not run smoothly.

but if i turned off, my wireless connection cannot connect to the network.

Why we should get the ? because my laptop is engaged with factory machine that we have get the data on it. that machine is only know the address.

How do i resolve this problem ?

I'm use the karmic.