View Full Version : [SOLVED] Places - home link broken

November 21st, 2009, 04:46 PM
Did a clean install of 9.10. I have my /home on a different partition. When I try to open /home from places, F-spot tried to open and failed (probably a different issue with F-spot). I removed F-spot and now I get an error: Could not open location 'file:///home/myusername'. I am able to get to my /home through the filesystem or using terminal; it is through Places that I am unable. I think that there is a broken link, but I am unable to find it.

I made sure I chose an application to open the folder, nautilus (file browser).

Any ideas?

November 21st, 2009, 04:51 PM
Is this what you tried? Right clicking on any folder in your file browser (Nautilus) and select "Open With", Other Application, and then File Browser?

November 21st, 2009, 04:54 PM
Yes, and that works.

Only when I go from the Main Menu - Places - Home (or any other file connected to /home do I get the error).

Error: "Failed to execute child process "f-spot-import" (No such file or directory)"

November 21st, 2009, 05:19 PM
You might try looking at ~/.local/share/applications/mimeapps.list to see if fspot is listed there or if nautius is registered.

Here is what my line looks like:


A quick way to view it:

grep "inode" ~/.local/share/applications/mimeapps.list

A more aggressive remedy may be to rename .local to something else. A new .local folder will be regenerated when you log off and log back in.

November 21st, 2009, 05:31 PM
Thanks. I think that I fixed it. The linking appears to work. Not sure how the "f-spot-import.desktop" got there.

The file had this on the line:

Changed the line to read: