View Full Version : [ubuntu] 9.10 install kernel problem

November 21st, 2009, 01:03 AM
Following an install of 9.10 over 9.04 from a LiveCD Grub showed several kernel options, the most recent being 2.6.31-15-general. Booting with this kernel is successful:

$ uname -a
Linux rjslptp 2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:54:29 UTC 2009 i686 GNU/Linux

When I checked in Synaptic to see what had actually been installed with respect to 'linux-images' only references to 2.6.31-14 are present.

How is this possible?

My wifi card which worked fine in 9.04 wasn't working:

$ lshw -C network
WARNING: you should run this program as super-user.
*-network UNCLAIMED
description: Network controller
product: PRO/Wireless 3945ABG [Golan] Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:0c:00.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: latency=0
resources: memory:ecfff000-ecffffff

Checking to see if the driver module was loaded:

$ lsmod
Module Size Used by
usbhid 38208 0
dm_raid45 84228 0
xor 15620 1 dm_raid45
ohci1394 29900 0
ieee1394 86596 1 ohci1394
video 19380 0
output 2780 1 video
tg3 109600 0
intel_agp 27484 0
agpgart 34988 1 intel_agp

gave very few results compared to what I remember from previous installs.

In /lib/modules and /lib/firmware there were '2.6.31-14-generic' folders but none for '2.6.31-15-generic'.

Does this make sense?

Thanks for your assistance.

November 21st, 2009, 01:16 AM
I had been using 2.6.31-15 and people here suggested that my weird issues might have been related to this version of the kernel. Apparently, -15 is a proposed kernel but not yet an official release.

I've gone back to -14 to see if it makes a difference. With -15, when my wireless connection crapped out I'd have to reboot to get back online.

November 21st, 2009, 03:26 AM
Thanks Slumberdog.

I think I tried the -14-general after upgrading but had the same result with wifi. I'll try it again but how do I get the iwlwifi-3945 driver running? It looks like there are two of them in /lib/firmware:

iwlwifi-3945-1.ucode & iwlwifi-3945-2.ucode

November 21st, 2009, 11:50 PM
I tried -14-general again and found that Firefox froze and crashed the system so I reverted to 2.6.28-16-general.

Wifi doesn't work and modprobe can't even find the loaded modules:
lsmod shows the tg3 driver but modprobe can't find the module being used

$ modprobe tg3
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Could not load /lib/modules/2.6.28-16-generic/modules.dep: No such file or directory

I found Gzip archives for all three kernels, listed in Grub as mentioned in a previous post, in /boot; e.g. initrd.img-2.6.28-16-generic

Only -14-general appears in /lib/modules and is detected by Synaptic. Can I just click on the other Gzip archives and have them install in the right place?