PDA

View Full Version : [SOLVED] 9.10: DVB-T No Lock on almost all channels



dibuntux
November 20th, 2009, 03:42 PM
Hi everybody, I'm running out of ideas. We just completed DSO (Digital Switch Off) for DVB-T and as a result Myth is not capable of locking on almost any channels.
Before the DSO everything was normal. So you may think it is a signal problem - not so. The signal actually increased 10/20 %

I've a splitter on my antenna cable, and I connected a cheap STB DVB-T to a standard TV set: all over 250 channels scanned and found correctly, signal at over 90%.
On myth, I can scan the Transport (with ignore signal timeout), but then on the founded channels I have No Lock, BE 65535 but a good (and variable) signal, ranging from 64 to 74% (before the DSO never got more than 64% on any transport).
The only channels that I can watch are on a 7 MHz VHF transport (RAI).

If I use VLC, I can lock on all channels, even HD channels. Sometimes, depending on transport, VLC may require some 5 secs to lock on to the channels.

DVB-S works well as usual, even if I noticed that after the upgrade from 9.04 to 9.10, when switching LNBs (I have 2 on DiseqC) sometime I get partial lock; if I change to another channel i got a lock, switch back to the previous channel and get lock again - did not happen with 0.21.
Everything else is fine.

I tried everything, even deleting and re-adding the DVB-T card, results are the same.

Any ideas? TIA

Mythbuntu 9.10 AMD64
Gigabyte GA-M720
Athlon X2 4800+
Nvidia 8400GS 1GB
WD Sata2 CaviarGreen
Skystar 2 DVB-s
HVR1110 DVB-t

dibuntux
November 22nd, 2009, 02:54 PM
Ok, after a LOT of trying, I solved this.

------------------------------------------------------------
MYTH DEVELOPERS take note: DVB-T scan is broken
------------------------------------------------------------

As I said, I've a splitter on my antenna cable, and I connected a cheap STB DVB-T to a standard TV set. On this particular model (mp@man) if you double press INFO button, you get ALL the info related to the Multiplex you are watching:
Freq Ch FFT Mod Gi Feq PID Signal% - so for example:
754Mhz 56 8K 64QAM 1/4 5/6 620 77%

From another table or wscan (which is unable to get all those parameters), I also got the Band, 8 MHz in the above case.

I erased all channels. I Inputed MANUALLY those parameters in the Transport settings on Myth and did a rescan for the transport.
I got the same channels as before, BUT NOW THEY ALL GET A LOCK!
Modified all others Transport with the info from the cheap STB receiver and rescan - now everything works.

So the moral of the story is: Myth cannot reliably scan a transport using Auto as a parameter for the above sections - You need to have those from somewhere else, or the scanned channels will not get a lock (or partial lock).

This was probably the most annoying problem I found on Myth - and the most undocumented one.

It is sad that a cheap STB can scan correctly and Myth cannot - but hey, what-the-heck, besides this Myth ROCKS!

Hope this helps others with DVB-T

paul-cyt
May 21st, 2010, 11:27 AM
I gave up with Myth in the end. I was ready for some rough edges, but a basic channel scan and display guide data should be rock solid. Windows 7 has been running for a few months now...

Maybe one day if myth people can get more of the basics 'working out the box' I'll re-try again. You might want to read about the hoops a jumped through just to get firmware!

http://ubuntuforums.org/showthread.php?p=9291967#post9291967

Good luck to others with Myth.