PDA

View Full Version : Java Applet problem



nzuri
November 18th, 2009, 10:49 PM
Hi.

i'm sorry to come back to this old topic, but i have problems with running java applications.

i have installed the packages sun-java6-jre and sun-java6-plugin (also jdk), but the applets don't work...

when i run them out of Netbeans i get the message: start: applet not initialized. and when i try to open applets with firefox i see a gray box instead of any applets.

i googled and read articles for 3 hours, but no change after reinstallation or anything else.

i hope someone can help me.

greez nzuri

p.s.: when this is the wrong forum i'm sorry, but i didn'n know where i should post it.

meson2439
November 19th, 2009, 08:42 AM
What is the name of the app, where I can find it? If it is something you create yourself, can you show us the code, as well as the debug information. That might solve your problem. There is not enough information atm.

froggyswamp
November 19th, 2009, 09:44 AM
You'll have to post your code otherwise you're basically wasting yours and peoples time.

nzuri
November 19th, 2009, 02:19 PM
ok, on appletviewer applets are running, i didn't know that i have to delete the packagename in applet class... by the way, why i have to comment the package name in the applet class?

btt:

in my browser java still isn't running.

tried with several applets:
http://home.arcor.de/hirnstrom/minis/index.html#bitorgel
http://www.walter-fendt.de/ph14d/kepler1.htm
just two of them.
and my own, which works in appletviewer...

java plugins are active in firefox (from 1.1 to 1.6)

nzuri
November 19th, 2009, 02:45 PM
i'm sorry that i stole your time. but i got it working.

when i saw it works in appletviewer, i knew it must be a problem in firefox.
i reinstalled firefox and now all applets are working, even without java6-plugin

thank you